WordPress.org

Forums

Related Posts by Zemanta
[resolved] Thumbnails Missing (3 posts)

  1. sfzip
    Member
    Posted 1 year ago #

    Some thumbnails are displaying default abstract images, though pics are properly sized in posts. Other thumbnails are pulled from posts as intended. Can't seem to find any correlation that would cause this.

    https://www.ziprecruiter.com/blog/

    https://wordpress.org/plugins/related-posts-by-zemanta/

  2. silvoslaf
    Member
    Plugin Author

    Posted 1 year ago #

    Hey, thanks for reaching out, I'll gladly help! And thanks for the link!

    Are those images in those blog posts (that are showing up wrong, generic thumbnails) stored in your Media Gallery or somewhere else? Have you changed those images along the way? Are you using any custom gallery plugins, with which you are inserting those images in? If so, which one?

    I'm sorry for all these questions, but I'm really eager to help you out here. But I do have a couple of suggestions for you as well:

    1.) try to set those images that you would want as your thumbnails as featured and see if this changes anything.

    2.) Even better — try to remove those images from your Media Gallery completely and insert them again. And run the 'Regenerate Thumbnails' plugin after that.

    3.) If those two solutions stated above don't work, try to one with 'Custom Fields' described below.

    Then open up the edit page of one of your blog posts, open the 'Screen Options' drop-down menu on the top right corner and tick the box next to 'Custom Fields'. A new widget called 'Custom Fields' should appear just below your editor, where you can add a new name (e.g. "Zemanta_thumbnails") and a value (link) to the image which you would like to use as a thumbnail for that particular blog post.

    Finally, go to your plugin settings and tick the box next to 'Use custom field for thumbnails' and select the "Zemanta_thumbnails" custom field value (or whatever you chose to name it).

    This way, you only change the value of your future (or past) blog posts, but the name of that custom field stays the same.

    Either way, do let me know how it goes! I'm looking forward to your reply!

    Best,
    Silvo

  3. silvoslaf
    Member
    Plugin Author

    Posted 10 months ago #

    Hey,

    hope you don't mind, but we'll mark this topic as resolved as there was no response from the original author for more than a month.

    If you find yourself with any other questions or if there's anything that's not completely clear, do let us know, since we'll gladly help!

    Take care & have a nice day!

    Best,
    Silvo

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic