Support » Plugin: WordPress Popular Posts » Thumbnails have stopped working with WP 3.5

Viewing 15 replies - 16 through 30 (of 48 total)
  • Plugin Author Hector Cabrera

    (@hcabrera)

    Hi gormley,

    Thank you for the update. Actually, I was just testing that and came here to ask you about your PHP version & the GD library since my plugin checks for these in order to enable / disable access to the Thumbnail feature.

    To all: please make sure your current hosting runs PHP 5.2 or newer and has the GD extension enabled, otherwise thumbnails won’t work.

    This is the response I get from one.com – my provider and for a million other domains:

    “For image processing we offer GD2, but not ImageMagick”.
    http://one-docs.com/specs/

    No thumbnails display on my site, so how do we fix this?

    Alright, a little update here. Found out why the images stopped working, it appears WordPress has changed the way images are attached to posts with 3.5, so setting Thumbnail source to First image on post will get you no results and no thumbnail. The Featured image option seems to be working fine, though.

    Will that be fixed in the plugin or do I have to go through ALL articles at set them to “featured image”?

    Thanks!

    Plugin Author Hector Cabrera

    (@hcabrera)

    Hi Dantes100,

    Nope, as a matter of fact the development version fixes that problem (as reported by other users). It will be pushed as official release after implementing/testing a couple of new features that hopefully you all will like.

    @cabrera,

    Your response is perhaps OK for some, but on quite a number of WordPress sites this does not work at all, as I have tested your development version and it does not work with providers using GD2 and no Imagemagic.

    Se my previous post for details.

    Morten

    Plugin Author Hector Cabrera

    (@hcabrera)

    Hi Morten,

    I saw your previous response and would like to know, are you able to upload images using WordPress’ Media Uploader?

    Hi Héctor,

    I only use the media uploader, and yes I’m using it without any problems in latest WP also – for posts with one or more images.

    Plugin Author Hector Cabrera

    (@hcabrera)

    OK, I’ll take a closer look then. Will let you know when the development version gets updated again so you can help me test it, alright?

    Excellent!

    I’ll test 😉

    Plugin Author Hector Cabrera

    (@hcabrera)

    Alright guys, just updated the development version again. Get it while it’s still hot here.

    To those interested in the technical stuff, I added support for the WP Image Editor class (introduced with WordPress 3.5) which allows me to create images on-the-fly using native WP code. A very nice addition from our WP developers!

    Anyways, please give it a try and let me know how it goes for you. Morten, I’m specially interested in getting your feedback as well, so please post whenever you get some chance to try it.

    Hi Héctor,

    Just applied the development version, and I get No Thumbnail as before, unfortunately.

    The only way it will display thumbnail is if I specify featured image.

    I’m keeping it active for a couple of hours, so you can check it out.

    Plugin Author Hector Cabrera

    (@hcabrera)

    Jeez, must be pretty tired but can’t seem to find your site’s URL. Can you please post it here so I can go take a look?

    It’s in my wordpress profile, but here it is: http://ross.no. Let me know when you’re back, and I’ll revert back to dev version again.

    Plugin Author Hector Cabrera

    (@hcabrera)

    I see you reverted back already, so I couldn’t take a look. I’ll be on for a few hours now, so please let me know once you get some spare time to test the development version again.

    Nice blog, btw!

    I’ve activated the current beta again.

Viewing 15 replies - 16 through 30 (of 48 total)
  • The topic ‘Thumbnails have stopped working with WP 3.5’ is closed to new replies.