Support » Plugins and Hacks » Thumbnail path is incorrect

Thumbnail path is incorrect

  • Thank you for your wonderful plugin. I upgraded from 2.3.2 to 2.3.5 today and my images disappeared. Based on this forum, I updated to 2.3.6 and it still didn’t fix the issue. Note I’m also using WTC with CloudFront and S3 as a CDN.

    PHP: (updated to use post_html instead of pattern_form)
    &post_html='<li class=\”sidebar-most-popular-news-with-image\”><div class=\”sidebar-most-popular-news-image\”>{image}</div><div class=\”sidebar-most-popular-news-text\”>{title}</div>’

    The plugin will output src=”http://s3.mbtcdn.com/news/wp-content/uploads/2013/06/outlivingretirement-featured-122×91.jpg”

    But in reality it’s src=”http://s3.mbtcdn.com/news/wp-content/uploads/2013/06/outlivingretirement-featured-122×85.jpg”

    Our thumbnails vary in height, so it’s not like I can force “thumbnail_height=85” and this will automatically work, since other images will be broken.

    I looked through the source code but 2.3.2 and 2.3.5 look quite different


Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Hector Cabrera


    Hi Jason,

    I just uploaded a test version here that hopefully fixes the problem. Could you please try it out?

    Also, which thumbnail source did you set in Settings > WordPress Popular Posts > Tools?

    I tried that version and cleared the cache, but still incorrect paths.

    Thumbnail source is set to “Featured image”. Is it possible to set it to one of my custom image sizes?

    Plugin Author Hector Cabrera


    Alright, thanks for the response. That means there’s an extra thing to do, but should be fairly simple since it already works with the “First image on post” option.

    About the thumbnail size, you’re already setting custom image sizes with the thumbnail_width / thumbnail_height parameters on the wpp_get_mostpopular() template tag. Thumbnail source simply tells WPP where to get the images from.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Thumbnail path is incorrect’ is closed to new replies.