Support » Fixing WordPress » thumbnail not working

  • Resolved c

    (@igneous)


    I just upgraded to 2.7, and I got the flash uploader to work by uploading the wp admin and includes files again directly through ftp. But now when I upload pictures it wont let me insert them into the post unless its full size. I cant select thumbnail, medium, or large, just full size. What is causing this?
    Thanks

Viewing 12 replies - 1 through 12 (of 12 total)
  • c

    (@igneous)

    I really cant figure this out, its not working on any of my 2.7 installations(all on the same domain same server)

    c

    (@igneous)

    See how the thumbnail, medium, and large part are greyed out?
    http://i35.tinypic.com/2cwubu9.png
    has anyone seen that problem before?

    c

    (@igneous)

    could it be a permissions issue? I tried to 777 eveything so I doubt that it is. I also copied over all of the wp-admin and inlcudes files over too and it didnt work. Is there a certain file that does the picture resizing?

    skemple

    (@skemple)

    I was able to fix this by upgrading/installing the php gd image library on my server. My server is running Ubuntu so it was just a matter of typing this command from the terminal sudo apt-get install php5-gd

    After it installed, I restarted my Apache webserver. and the different sizes were working again when uploading images.

    Hope this helps at least get you on the right track.

    c

    (@igneous)

    thank you, that worked!

    janderbrazil

    (@janderbrazil)

    Hi,

    I’m having the same problem, but I could figure out what to do.
    I’ve upgraded to 2.7 and the thumbnail, Small and Medium Sizes options turned grayish and I no longer can use those options, only Full size.

    Can anybody give me a hand with that? I have 3 very important blogs with thousands of visitors everyday, I can’t have these kind of silly problems!

    Sorry folks…hope someone can help me!

    Cheers,

    J.

    c

    (@igneous)

    Do what skemple said. If you dont know how to do that your host might be able to help. It worked as soon as I did that

    My host does have the DG Lib installed and I still got the same problem

    I am running my own host. I’ve got php 5.2.5 installed with gd 2.0.34 enabled. I’m having the same grayed-out problem.

    I’ve tried re-copying the wp-includes directory, and chmod’ing my entire uploads directory to 777. Tried different browsers. Tried different images.

    I think I just found the problem. Uploading a .png instead of a .jpeg works – so I’m guessing somehow my libjpeg didn’t get included in gd.

    Just thought I’d give the heads-up!

    For me, it was working I believe up until WP 2.7 and now it’s not.

    I am running a Windows Server 2003 machine with PHP, MySql, and IIS.

    I have made a post for this issue here:

    http://wordpress.org/support/topic/231020

    I have never had GD installed, but I’m not clear how I would know/go about it anyway. Can anyone confirm this was changed/broken with 2.7?

    Is there any documentation on GD now being required?

    Is there seriously no one at all that can point me to any official documentation from wordpress that this GD library is now required?

    justatest47

    (@justatest47)

    I have a big problem!
    When thumbnails work fine only if I upload an image for each post. If I try to use a picture from the media library that has already been uploaded to another post, the thumbnail doesn’t work!!!
    So I really don’t want to upload the same picture 10 times (for each article)!

    How can this be fixed? And how about thumbnails from URLs? Is it way to much to ask for?

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘thumbnail not working’ is closed to new replies.