The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

Thumbnail not created problem. (4 posts)

  1. laurendw
    Posted 11 years ago #

    I have the infamous "Filetype not supported. Thumbnail not created." error message when I upload a JPG file and try to create a thumbnail. The image itself uploads without problems. My current sample is only 164 KB. I'm using WP 1.5 and no image plugins. My options have "jpg jpeg gif png" for the allowed file formats.

    I'm running Debian and mostly using the stable distribution. I first made sure that GD was installed, but that didn't solve the problem. Then I read in the forums that the problem could be the version of PHP4, so I installed the PHP 4.3.10 from Debian unstable, as well as PHP4-gd2. The php.ini file has the "extension=gd.so" line in it, uncommented. The only places that "gd" shows up in phpinfo.php are "'--with-gd=shared,/usr' '--enable-gd-native-ttf' ".

    Any ideas? Anything I can check to find out what might be stopping the thumbnail code from working?

  2. James Huff
    Support Team Rep.
    Posted 11 years ago #

  3. laurendw
    Posted 11 years ago #

    Yes, I searched first. And read the threads. And tried the suggestions (except for upgrading to PHP5, which I don't want to do). Nothing worked, so any ideas would be welcome.

  4. laurendw
    Posted 11 years ago #

    I found the answer - it turns out that although one of the packages reinstalled with all the PHP4 and GD upgrades was apache, and apache was restarted during the upgrade process, I needed to restart it one more time to get the GD library to "take".

Topic Closed

This topic has been closed to new replies.

About this Topic