Support » Plugin: WPSSO Core | Complete Meta Tags and Structured Data SEO for WordPress » Thumbnail missing from SSO Image posts column

  • Resolved mikehermary

    (@mikehermary)


    Hello,

    Our website is running WordPress Network multi-site and one of the sites is having issues displaying thumbnails in the SSO Image column when viewing all posts. The column itself is displayed as shown in the attached image, but is empty and none of the expected HTML is rendered in the table cells. This is the HTML that is outputted:

    <td class="wpsso_og_img column-wpsso_og_img" data-colname="SSO Image"></td>

    Screenshot of posts view and missing thumbnails

    Any help is greatly appreciated.

    Cheers,

    • This topic was modified 7 months, 3 weeks ago by mikehermary.
Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author JS Morisset

    (@jsmoriss)

    It sounds like the images WPSSO is able to detect are too small. When editing a post/page, WPSSO will show any image related warnings in the SSO notification area of the toolbar. See here for more info: https://wpsso.com/docs/plugins/wpsso/faqs/how-does-wpsso-find-detect-select-images/

    js.

    Thread Starter mikehermary

    (@mikehermary)

    Hello,

    Thanks for the reply.

    There are no image related warning for the specific site and all of the images attached to each post are a good size.

    When I view the Priority Media section for an individual post, nothing is displayed in the Image ID and URL text fields. The attached screenshot shows how the same story on a different networked site displays the image data in the Priority Media section.

    Priority Media for two posts on different network sites

    Cheers,

    Plugin Author JS Morisset

    (@jsmoriss)

    As I said, it sounds like the image provided by WordPress is unsuitable. When editing an example post/page, what is the SSO notification message? There will at least be one message saying there are no messages, but more than likely, there will be image related warnings. Please copy-paste the notification message(s).

    js.

    Thread Starter mikehermary

    (@mikehermary)

    Hello,

    When I go to edit an existing post, the following SSO Notice is displayed: Plugin settings have been upgraded and saved. A background task will begin shortly to clear all caches. This is only one that is displayed.

    All posts on the affected network site do not have SSO images. They do have the featured properly sized and set, and Yoast SEO is properly showing the image.

    When I view All Posts, the following SSO notices are displayed:

    • Transient cache refresh task started at 2020-08-26T17:18:59+00:00.
    • 0 cached files, 4 transient cache objects, 0 column metadata, and the WordPress object cache have all been cleared. The total execution time for this task was 3.078 seconds. A background task will begin shortly to refresh the post, term and user transient cache objects.

    Cheers,

    • This reply was modified 7 months, 3 weeks ago by mikehermary.
    Plugin Author JS Morisset

    (@jsmoriss)

    When you posted your question, you did not provide a URL to an example post/page, so I cannot provide specific information. Generally, the issue you describe happens when WordPress cannot provide a large enough thumbnail (aka, the Open Graph image) to WPSSO, so when editing the post/page, you should see an image related warning. You may want to try and update the post/page to see if there’s a caching issue, although caching issues are rare (unless you’re using W3TC, in which case they are expected). If the original image is large enough, then perhaps WordPress is having issues creating the required thumbnail. You could try the usual – defining WP_DEBUG and activating the Query Monitor to check for errors. See here for more info: https://wpsso.com/docs/plugins/wpsso/installation/troubleshooting-guide/

    js.

    Thread Starter mikehermary

    (@mikehermary)

    Hello,

    My apologies for the delayed reply.

    I have tested this issue on our staging site with caching disabled completely and it still occurs.

    I have also enabled debugging with the Query Monitor plugin activated, but nothing comes up related to SSO and images when viewing the all posts on the affected network site.

    I reviewed the troubleshooting guide, but was not able to adjust any of the settings as we are not using the premium version of the plugin.

    As stated before, this issue is only affecting one of our network sites. All of these sites perform the same way, but only one is missing images in the SSO Image column.

    Any additional assistance would be greatly appreciated.

    Cheers,

    Plugin Author JS Morisset

    (@jsmoriss)

    Make sure the WordPress “thumbnail” image size has not been disabled on that site, as that is the image size WPSSO Core requests from WordPress.

    js.

    Thread Starter mikehermary

    (@mikehermary)

    Hello,

    The thumbnail image sizes are set to the same values on all of the sites.

    Cheers,

    Plugin Author JS Morisset

    (@jsmoriss)

    The WordPress media library can get corrupted sometimes, so this may be the case here – you may want to try regenerating the media library image sizes with a plugin like this one: https://wordpress.org/plugins/regenerate-thumbnails/

    I’ve added extra HTML comments in WPSSO Core v8.4.1, so you could also do a View Source on the table cell – the comment should look like this:

    
    <td class='wpsso_og_img column-wpsso_og_img' data-colname="SSO Image">
    <!-- getting thumbnail size for image id 123 = success -->
    <div class="wp_thumb_bg_img" style="background-image:url(http://.../wp-content/uploads/image-150x150.jpg);">
    </div>
    <!-- .wp_thumb_bg_img -->
    </td>
    

    js.

    Thread Starter mikehermary

    (@mikehermary)

    Hello,

    This issues seems to have been resolved by updating to the latest release of SSO. Thanks for your assistance.

    Cheers,

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Thumbnail missing from SSO Image posts column’ is closed to new replies.