Support » Plugin: WordPress Popular Posts » Thumbnail issues

  • Resolved zeshark


    I was planning on using the first image on post to gather the thumbnail, but it turns out that it apparently seeks the first uploaded image on the post.

    All of our post images come from a nextgen gallery and are linked that way:

    gallery_name varies from post to post.
    Am I correct to understand that using the custom field to specify a URL path will therefore not work ?

    Is the only solution to take the Featured Image route ?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Hector Cabrera


    Hi there,

    It should be OK to use a full path on the custom field. About the first comment, yes the plugin uses the first uploaded image but maybe that’s not the best option and I may change that soon so WPP picks up the first image found on the post.

    Thanks for your reply, Hector. The problem with specifying the path is that gallery_name in the path will change from post to post, I don’t quite see how this could work.

    Is it a complex mod to pick the first linked image rather than the first uploaded image ?

    I’ve meanwhile tested the feature post avenue.
    Checked the FAQs too:
    – /wp-content/plugins/wordpress-popular-posts/cache exists and writable
    – GD library loaded on web server (2.3.7)
    – added featured images to test posts
    But I still get broken images.

    Cache contains:
    – timthumb_cacheLastCleanTime.touch
    – index.php
    Both empty.

    When I try to view one of the generated thumbnails, I get:

    A TimThumb error has occured

    The following error(s) occured:
    Could not create the index.html file – to fix this create an empty file named index.html file in the cache directory.

    Query String : src=
    TimThumb version : 2.8.10

    Problem is, index.html does exist in the cache directory.
    Any hint ?

    Plugin Author Hector Cabrera


    It could be a problem with permissions. The cache folder needs to be writable. Try creating an empty index.html file and upload it to the cache directory.

    Thanks, that worked !
    I created a new empty index.html, gave it 777 permissions and my thumbnails are now showing up based on featured images.
    I guess that changing folder permissions was not enough, because the file itself was in 644.

    I am however a bit nervous about leaving an html file in 777, what is the minimum permission level required by by TimThumb ?

    Plugin Author Hector Cabrera


    Try chmodding it to 755.

    Thanks for the suggestions, Hector.
    I tried 755 and 775, but both result in empty thumbs being displayed. The only premission that seems to work is 777.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Thumbnail issues’ is closed to new replies.