Support » Fixing WordPress » Thumbnail images

  • As of today, when I upload an image from my computer, it will only let me select the “full size” option and not thumbnail or medium. I read the sticky post above, but this isn’t a problem with the images — I’ve reuploaded images today that I had no problem with in the past and it happens with them too.

    Any ideas what the problem could be?

Viewing 9 replies - 1 through 9 (of 9 total)
  • I too have updated to version 2.7.1 and have hit the same problem … it will now only let me select the “full size” option and not thumbnail or medium. I tried it on pc and mac and both browser upload and flash.

    Am unable to update my site until I find an answer ….anybody else suffering from this apart from bpeck and myself ?


    bpeck … try switching off your plugins and then trying to upload your images …. the radio buttons should now work to change the size of your images … then put back on your plugins one by one until you can work out which one was causing the problem


    This might be sound like woffle – but its something I came across.

    In recent versions of wordpress the naming conventions of thumbnail filenames changed – this causes an issue when trying to view the gallery – it finds no file named appropriately. What you end up doing is having to re-zig your old files by re-editing old posts, reuploading images – and deleting the old ones.

    Thats one scenario.

    The second scenario (well maybe should be first to be checked) is to verify your settings for your image folder are the same as before upgrade – i.e. in settings -> miscellaneous check the media folder is set correctly.


    I started another thread on this same issue yesterday. However, for me it is not associated with an upgrade to 2.7 but a new install. No size option – other than full size – available for any image that I upload.

    All other options work fine and I can use the image edit mode to “resize” the image.

    Not sure exactly if I get what you are saying artsnova but there are image size settings in Settings->Media???

    At least in version 2.7.1 sure there was some sort of option in previous versions. The biggest change/annoyance came when wordpress naming conventions changed for thumbnails and images overall (i.e. the size was appended to the image names once uploaded).

    Hi hotkee,

    I’m referring to the dialog associated with the “Add an Image” icon. Once I’ve uploaded an image all the options available in the dialog work except for the size options. The Thumbnail, Medium, and Large options are all grayed out and are not selectable. Full size is chosen by default.

    Once I’m back in the visual editor I can click on the image and use the edit image option to resize the image to some fraction of its original size. I don’t really have a use for that capability though.

    Hopefully someone has experienced the problem I’m having and knows what fix is needed to get the Thumbnail, Medium, and Large options enabled.

    I have the exact same problem!

    All the size options are not selectable except full size. I’m running WordPress 2.8.6. Image settings in Settings>>Media are set to the sizes I want them to be and I even changed them slightly just to see if it would kick in after editing. Still no sizing options upon upload or after the fact (accept the %-scale on the side) but I don’t want to rely on that, it should work the way it was intended to.

    Please help!


    I should start listing out the number of threads that duplicate this question, and all of them have yet to provide an answer. Still looking myself.

    This is caused by the GD library either not being correctly installed or updated in Apache hosts. Reinstall or make sure GD libraries are enabled and working properly. Otherwise this is the exact problem you’ll get. If you don’t host your own WordPress, ask your host to investigate why GD isn’t working properly on your server.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Thumbnail images’ is closed to new replies.