WordPress.org

Forums

nrelate Related Content
Thumbnail images loading slowly (11 posts)

  1. boatgalley
    Member
    Posted 2 years ago #

    I've just done a bunch of work to speed up my site and all is going well except that the thumbnails from the Related Content are often (but not always) loading slowly from imgcdn.nrelate.com.

    I've tried using both the Javascript and non-Javascript versions, but I get the same thing, although seem to have somewhat fewer problems with the JS.

    Any ideas of things to try . . . other than not using thumbnails? Don't really want to do that!

    Thanks!
    Carolyn
    http://theboatgalley.com (look at a post, there aren't related posts on the home page)

    http://wordpress.org/extend/plugins/nrelate-related-content/

  2. @boatgallery -- Thanks for using nRelate on your site. We actually use CDN so that images load faster so this shouldn't be an issue. We checked it out and images load well on our end. Are you still having this problem on your end? If so, would you like to meet with us over webex so we can see the issue first hand? Then we can collect some data that we can send to our CDN provider to see what might be going on.

    [ Signature moderated. ]

  3. boatgalley
    Member
    Posted 2 years ago #

    I still have the problem, but it IS intermittent -- testing on the same post, I'll have different results just a minute apart. I've taken some screenshots of the tests -- # 1 and 2 show problems, but not on the same thumbnail, then #3 shows them all loading fairly quickly.

    Test 1
    Test 2
    Test 3

    I'm happy to try to meet with you but not sure what I can tell you that you can't just see on WebPageTest -- the page I keep testing with is http://theboatgalley.com/tortilla-stuffers-5-minute-meal/ and I'm just using all the default settings -- Dulles, IE9, and Cable (I see the problem with other pages and settings, that's just the one I use as a benchmark . . .).

    Thanks for looking into this further!

  4. Rongo
    Member
    Posted 2 years ago #

    An ideal solution here would be for nRelate to have a CACHE folder in standard Uploads folder and store the images locally for those who would prefer to NOT have their content show up on other sites.

    Thus, the option for "Local Only" or "Network Sharing". Where network sharing would store the thumbs on the CDN servers, and local only would allow the plugin to be truly self-contained on an end user's server.

    It's the storing of remotely hosted thumbs, versus locally hosted ones, that makes us reject this otherwise great plugin.

  5. @boatgalley -- Thanks for providing the additional info. We're looking into it on our end.

    [ Signature moderated. ]

  6. Native Imaging
    Member
    Posted 1 year ago #

    could this be caused by db tables? I'm also having extremely slow loading times on 150px thumbnails on one site... But can't seem to replicate the bug on other domains. Currently, each thumbnail takes about 3 seconds to load...

  7. @Native Imaging -- Can you let us know which site you use our plugin on so we can take a look for you?

  8. fapp
    Member
    Posted 1 year ago #

    Sorry to hijack this thread, but I'm having exactly the same problem. Do you know if anything has been resolved? I've just switched over from linkwithin and I like the format and options that come with nrelate.

  9. @fapp -- Can you let us know your site URL so we can take a look at the issue for you? You can also email support@nrelate.com if you don't want to link to your site on this forum.

    - Katrina @ nRelate

  10. fapp
    Member
    Posted 1 year ago #

    Hi katrina

    I've emailed but url is buttonsandbeeswax.com

    thanks

  11. @fapp -- Thanks for providing a link to your site. We've fixed the image issues for you and things should look good now. How does everything look on your end? You may need to clear your browser cache to see the changes.

    - Katrina @ nRelate

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic