Support » Plugin: BuddyPress Activity Plus » Thumbnail image disappears.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Bojan Radonic – WPMU DEV Support

    (@wpmudev-support4)

    Hey there tmh23,

    Hope you’re well today 🙂

    Would you mind posting link to your activity page so I can take a look?

    Best regards,
    Bojan

    League Activity

    Thanks,
    Troy

    Plugin Author Bojan Radonic – WPMU DEV Support

    (@wpmudev-support4)

    Hey Troy,

    Thanks for the link, I’ve checked your activity page and then did as you described (navigated to another page and went back) and the thumbnail image was still displayed there properly.

    Did you manage to fix this or am I missing something?

    Please advise,
    Bojan

    It still happens but seems to be random depending on the link. Photo uploads do not have the issue only links.

    Troy

    Plugin Author Bojan Radonic – WPMU DEV Support

    (@wpmudev-support4)

    Hey Troy,

    After investigating this further this seems to be related to mixed content error as your site is being loaded via HTTPS.

    While activity plus loads images from your server via HTTPS we can’t do the same for remote images (images that are not coming from your site such as thumbnails you get from links.)

    The reason this is random is because when image that you get from the link doesn’t have HTTPS version this will happen and when it has it will be displayed properly.

    There is not much that we can do about this currently, I’ll forward this information to our developer so he can possibly find a solution and add it in one of the following updates.

    Best regards,
    Bojan

    That makes perfect sense. Thank you for forwarding to the developer to see if anything can be done. Serving the site HTTPS these days I think makes people feel better about joining the site.

    Thanks, and I look forward to hearing back if there is a solution to this from the developer.

    Troy

    Also…. is there a way to not have the ‘read more’ happen if the link text preview is too long?
    It would be much cleaner not to have this display.

    Troy

    Plugin Author Bojan Radonic – WPMU DEV Support

    (@wpmudev-support4)

    Hey again Troy,

    Something like that yes, it would most likely have to include JS which would first check if the site is loaded via HTTPS and then request the HTTPS version of the image and in case there is no HTTPS version to fall back to HTTP or something else.

    I’m sure our developer will find a solution for this 🙂

    Cheers,
    Bojan

    FYI.
    This plugin solved this issue perfectly. Put the setting on ‘Capture’
    https://wordpress.org/plugins/ssl-insecure-content-fixer/

    Troy

    Plugin Author Bojan Radonic – WPMU DEV Support

    (@wpmudev-support4)

    Hey Troy,

    Awesome find! Thank you for posting this here so other members can benefit from it 🙂

    Have a great weekend!

    Cheers,
    Bojan

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Thumbnail image disappears.’ is closed to new replies.