WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Thumbnail Help with Suffusion Theme (8 posts)

  1. anguscarter
    Member
    Posted 1 year ago #

    Hi guys, so I'm having a little trouble here. I have my site setup with diffrent pages for different content. One of those pages is a "page of posts" where all my blog posts will be going. Have it setup and functioning properly where my new posts go straight to the page and show up as excepts, no problem there. I cannot however get a thumbnail to appear with the excerpts. The only way I can get it to remotely work is by setting a feature image for the posts but then that image also appears in the post which I don't want. I have in the post "additional options for suffusion: images" a url set for the thumbnail but it does nothing. I've also tried every setting in "appearance: suffusion options: layout: layout except...:thumbnail settings", in every combination I can imagine and still nothing. I read on other forums that if I take out the code
    <?php
    if(!is_single()){
    if ( has_post_thumbnail()) { the_post_thumbnail('thumbnail');}
    }
    ?>
    that it will remove the feature image from inside the post and that then the feature image would show on the "page of posts" as a thumbnail but not in the post itself. However that piece of code is not anywhere to be found (every forum says it should be single.php but it is not). So any advice? Is there another way to get a thumbnail for my "page of posts" or is this code buried somewhere else in suffusion? Anyone? Anyone? Bueller?
    Heres the site, the hill and the river and it is the blog section where my problem is. Also forgive the sloppy design for now, still working the kinks out before adding a bunch of content.
    Thanks
    -angus
    P.S. I am a newb with wordpress but am decently tech savvy and can follow directions.

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    I cannot however get a thumbnail to appear with the excerpts.

    That would be the expected behaviour. By design, the_excerpt() strips out all formatting and images. Perhaps you should replace it with the_content()? Are you using a child theme for all of this customisation?

  3. anguscarter
    Member
    Posted 1 year ago #

    Hi esmi, you are on top of it or maybe i just have good timing today.
    I am not using child theme, quite frankly i was not sure what that was. I've seen that option but in my mind child means less customization, so I opted not to fool with it. Should I be using it? I guess that is a tangent I'll goog here shortly.
    But back on point, maybe I misspoke saying "excerpts", sometimes common language takes on a different tech meaning. How I was doing what I call "excerpts" was adding the more tag in posts so it shows the "continue reading" button on my page of posts. So not sure if that is technically a "excerpt" or not. I will look for that code though and try to swap it, would that be in the single.php?
    Thanks!
    -angus

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    Should I be using it?

    In theory, yes. Otherwise, you risk losing all of your changes when you update the theme. That said, suffusion is a complex theme that is bordering on being a framework. Have you tried posting on the theme's dedicated forum: http://www.aquoid.com/forum
    You should get a faster & more informed response there.

  5. anguscarter
    Member
    Posted 1 year ago #

    Thanks again. I just was reading about the child themes and trying to figure out how to properly do it via my hosting, I guess there is no way to do it through dashboard is there. Luckily the only code i've changed so far is the size of my caption font, which is super easy. So I won't lose much if the theme gets upgraded before I figure out how to do the child themes properly. There again though, a tangent.
    The complexity of suffusion is kinda what I like, everything is completely unrestrained and customizable but your right it can be infuriating sometimes, especially when it doesn't troubleshoot in the same way as other themes. I will try their forum, thats a great idea that for whatever reason did not dawn on me.

  6. anguscarter
    Member
    Posted 1 year ago #

    Awesome, I got it.
    If anyone else comes across this and is having similar problems here how I fixed it. In "appearance: suffusion options: layout: layout excerpt...:" in your "thumbnail settings" under "Show featured images for full content" set to "Don't show any image." Then you have to double check in "appearance: suffusion options: front/blog page views" and make sure that you do not have "display full content" marked under "Full posts / excerpts / list / tiles / mosaic." If you have any of the other options marked it works but if full content is marked it will ignore your "featured image" in your page of posts just like it ignores it in your actual post.
    So problem solved!

    esmi- Thanks for your time and advice, keep up the good work!

  7. Sayontan Sinha
    Member
    Posted 1 year ago #

    @AngusCarter,
    I was just going to respond with this, but you found the solution yourself!

    Cheers,
    Sayontan.

  8. esmi
    Forum Moderator
    Posted 1 year ago #

    Glad to hear that you managed to solve this yourself. :-)

Topic Closed

This topic has been closed to new replies.

About this Topic