Support » Plugin: FooGallery - Image Gallery WordPress Plugin » Thumbnail Generation Error

  • Resolved kastali_bleikr

    (@kastali_bleikr)


    We are running a test site and updated to the latest version of FooGallery v.1.6.11. I have tried deactivating every plugin and that did not remove the error. I changed to the default 2019 theme and that did not fix the issue. We don’t have a caching plugin to clear. I even tried clearing the thumbnail cache from each gallery in the plugin, as well as Clear Gallery HTML cache and Clear CSS Optimization Cache all to no avail.

    I have a second WordPress install on this test server and it isn’t showing these errors at all.

    This is the error:
    Thumbnail Generation Alert!
    There is a problem generating thumbnails for your gallery. Please check that your hosting provider has the GD Image Library extension installed and enabled.
    If thumbnails cannot be generated, then full-sized, uncropped images will be used instead. This will result in slow page load times, and thumbnails that do not look correct.

    I checked and the GD Image Library is installed and enabled and we are using php7 for this test server.

    This is the error I get from trying the Thumbnail Generation Test:
    Thumbnail generation test failed!object(WP_Error)#2014 (2) { [“errors”]=> array(1) { [“image_no_editor”]=> array(1) { [0]=> string(28) “No editor could be selected.” } } [“error_data”]=> array(0) { } } array(2) { [“ext”]=> string(3) “svg” [“type”]=> string(13) “image/svg+xml” }

    I have no idea what is causing this. :/ Any help would be appreciated.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support phillcoxon

    (@phillcoxon)

    Hi @kastali_bleikr

    In most cases this error is caused by the PHP GD image extension not being installed on the server as indicated by the message you shared. Here’s another support request that details the issue:

    https://wordpress.org/support/topic/no-editor-could-be-selected-2/

    Other issues could be lack of PHP memory during image resizing. How much memory does your WordPress hosting have set for PHP?

    Are you also able to post the info generated by FooGallery -> System Info here so we can review?

    So I’m pretty dang sure that an image processing extension is installed. I don’t see why it wouldn’t. I checked another WordPress install and it didn’t have this issue. I even deleted all the galleries and removed the plugin. I reinstalled the plugin and the error persists.

    The memory limit is set to 256MB. Here is what is posted in the System Info from FooGallery. Keep in mind I have turned all plugins off except FooGallery:

    FooGallery version : 1.6.11
    WordPress version : 5.0.3
    Activated Theme : Customizr Pro Child
    WordPress URL : https://new.901memlib.org
    PHP version : 7.0.33
    PHP GD : Loaded (V2)
    PHP Open SSL : Loaded
    PHP HTTP Wrapper : Found
    PHP HTTPS Wrapper : Found
    HTTPS Mismatch : None
    PHP Config[allow_url_fopen] : 1
    PHP Config[allow_url_include] : 1
    Extensions Endpoint : https://raw.githubusercontent.com/fooplugins/foogallery-extensions/master/extensions.json?v=So5sBT&$S$Xx
    Extensions Errors : Nope, all good
    Extensions :
    Extensions Active : Array
    (
    [0] => default_templates
    [1] => foobox-image-lightbox
    )

    Gallery Templates : Array
    (
    [0] => default
    [1] => image-viewer
    [2] => justified
    [3] => masonry
    [4] => simple_portfolio
    [5] => thumbnail
    )

    Lightboxes : Array
    (
    [foobox] => FooBox (Not installed!)
    [dfactory] => Responsive Lightbox by dFactory (Not installed!)
    )

    Settings : Array
    (
    [gallery_template] => default
    [gallery_sorting] =>
    [default_gallery_settings] => 0
    [caption_title_source] => caption
    [caption_desc_source] => desc
    [thumb_jpeg_quality] => 80
    [default_crop_position] => center,center
    [language_images_count_none_text] => No images
    [language_images_count_single_text] => 1 image
    [language_images_count_plural_text] => %s images
    )

    Active Plugins : Array
    (
    [0] => foogallery/foogallery.php
    )

    I would like to mention that I ran a full uninstall in the plugin, deactivated it, and removed it. I decided to try and install an older version of the plugin. I have found that versions 1.5.9 or 1.6.1 show no errors. The thumbnail test generates just fine.

    Trying version 1.6.7 it generates an error just like 1.6.11. So it seems to be an issue with the newer versions of the plugin after 1.6.1 and this particular install of WordPress.

    Plugin Support phillcoxon

    (@phillcoxon)

    @bradvin – are you able to assist with this please?

    I just installed the newest version (1.6.14) and the generate thumbnail error isn’t showing up. 😀 I have no idea why that install on that server was having issues (other installs were not), but this update seems to have fixed it.

    Plugin Support phillcoxon

    (@phillcoxon)

    Hi @kastali_bleikr!

    That’s great to hear.

    I’ll mark this support request as resolved.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.