Support » Plugin: FooGallery Image Gallery – Responsive Photo Gallery » Thumbnail Generation Alert!

  • Resolved nin0

    (@nin0)


    Hello support team,

    After installing the plugin, i get this message on top of the galleries page (admin)

    Thumbnail Generation Alert!
    There is a problem generating thumbnails for your gallery. Please check that your hosting provider has the GD Image Library extension installed and enabled.
    If thumbnails cannot be generated, then full-sized, uncropped images will be used instead. This will result in slow page load times, and thumbnails that do not look correct.

    I have already contacted my hosting company and asked them to check it. The said that the GD Image Library extension is 100% installed and enabled.
    Do you have any idea what could be the problem?

    Thanks,
    Best regards
    Nin0

Viewing 15 replies - 16 through 30 (of 30 total)
  • i have the same issue (host gator vps)

    Plugin Author bradvin

    (@bradvin)

    @toad75 sometimes this happens when test thumb generation fails.

    Goto FooGallery -> Settings -> Advanced Tab

    Check the “Override Thumb Test” setting and click save

    Give that a try

    cluain404

    (@cluain404)

    Hi,
    I have this as well – Thumbnail Generation Alert!
    The only thing is, that the thumbnails are being generated.
    So is it safe to just ignore this alert?

    I’ve tried some of the suggestions above but didn’t notice anything different.

    Thanks

    Plugin Author bradvin

    (@bradvin)

    @cluain404 if the thumbs are being generated correctly, then you can ignore the alert.

    cluain404

    (@cluain404)

    Thanks very much.

    I am having this same issue at ExtinctDisney.com (hosted by BlueHost). The full error is:
    Thumbnail Generation Alert!
    There is a problem generating thumbnails for your gallery. Please check that your hosting provider has the GD Image Library extension installed and enabled.
    If thumbnails cannot be generated, then full-sized, uncropped images will be used instead. This will result in slow page load times, and thumbnails that do not look correct.

    I have tried checking the “override thumbs test” with no change. I’ve cleared FooGallery cache with no change.

    JboyJW

    (@jboyjw)

    I’m getting this error also:

    Thumbnail generation test failed!object(WP_Error)#5242 (2) { [“errors”]=> array(1) { [“invalid_image”]=> array(1) { [0]=> string(21) “File is not an image.” } } [“error_data”]=> array(1) { [“invalid_image”]=> string(69) “http://southerngeorgianbay.ca/wp-content/uploads/logo_midland-002.png” } } array(2) { [“ext”]=> string(3) “png” [“type”]=> string(9) “image/png” }

    It’s because I updated the website to use https instead of http. The images aren’t found because they have http://. I used the Better Search Replace plugin to properly find all http://southerngeorgianbay.ca and replace with https://southerngeorgianbay.ca, the rest of the site is working fine and is secure, but wherever the above data is store is not getting updated…

    Any suggestions?

    JboyJW

    (@jboyjw)

    Figured it out… the Better Search Replace plugin doesn’t replace text in guids by default… Once I forced that to happened, it worked.

    aracifcarvalho

    (@aracifcarvalho)

    I have the same problem
    Thumbnail Generation Alert!
    There is a problem generating thumbnails for your gallery. Please check that your hosting provider has the GD Image Library extension installed and enabled.
    If thumbnails cannot be generated, then full-sized, uncropped images will be used instead. This will result in slow page load times, and thumbnails that do not look correct.
    Already tried all suggestions but nothing works.
    Someone can help me please?

    hey here,

    I am trying to customize my thumbnail for fursuits for sale. this is the link please have a look at it and tell me. It is made from elegant themes. extra.
    If someone here has use this themes please help me. I read all extra forums but I cannot find it.

    thanks

    I am having the same problem one year later.
    1) ran test

    Thumbnail generation test failed!object(WP_Error)#6612 (2) { [“errors”]=> array(1) { [“invalid_image”]=> array(1) { [0]=> string(21) “File is not an image.” } } [“error_data”]=> array(1) { [“invalid_image”]=> string(40) “https://s3.amazonaws.com/foocdn/test.jpg” } } array(2) { [“ext”]=> string(3) “jpg” [“type”]=> string(10) “image/jpeg” }

    2) enabled the FooGallery setting “Override Thumb Test” under the advanced tab

    3) cleared cache, reran test, still having the same error

    • This reply was modified 3 months, 1 week ago by jjazzbel.
    • This reply was modified 3 months, 1 week ago by jjazzbel.

    Please check that your hosting provider has the GD Image Library extension installed and enabled.

    This worked for me

    Yes, I just checked. Hosting confirms Installed and enabled.
    Foogallery Systems Settings indicates it is loaded.
    FooGallery version : 1.9.25
    WordPress version : 5.4.2
    Activated Theme : Twenty Seventeen Child
    WordPress URL : https://www…..
    PHP version : 7.3.2
    PHP GD : Loaded (V2)
    PHP Imagick : Not found!
    PHP Open SSL : Loaded
    PHP HTTP Wrapper : Found
    PHP HTTPS Wrapper : Found
    HTTPS Mismatch : None
    PHP Config[allow_url_fopen] :
    PHP Config[allow_url_include] :
    WP Image Editor : WP_Thumb_Image_Editor_GD
    Thumbnail Generation Test : https://s3.amazonaws.com/foocdn/test.jpg
    Extensions Endpoint : https://raw.githubusercontent.com/fooplugins/foogallery-extensions/master/extensions.json?v=KWo)!jhx8CoL
    Extensions Errors : Nope, all good

    Nothing resolved: Fo Gallery still shows “Thumbnail generation error”. Ovverriding test and clearing cache does not help.

    Here ist the result of the test: Thumbnail generation test failed!object(WP_Error)#8263 (2) { [“errors”]=> array(1) { [“invalid_image”]=> array(1) { [0]=> string(20) “Datei ist kein Bild.” } } [“error_data”]=> array(1) { [“invalid_image”]=> string(40) “https://s3.amazonaws.com/foocdn/test.jpg” } } array(2) { [“ext”]=> string(3) “jpg” [“type”]=> string(10) “image/jpeg” }

    Besides, my provider does not habe the Module “imagick” – but I do not think this is the questeion.
    My site https://aschihaas.ch is running without problems, so it seems we have no possibility to get rid of the message. Should we simply ignore it?

    Tanks for for any suggestion, Aschi

    Plugin Author bradvin

    (@bradvin)

    I have made some improvements to the thumbnail generation test code, which I think will help. These updates will be released in v1.9.27 of FooGallery

Viewing 15 replies - 16 through 30 (of 30 total)
  • You must be logged in to reply to this topic.