Support » Plugin: WordPress Responsive Gallery Plugin - FooGallery » Thumbnail Generation Alert!

  • Resolved nin0

    (@nin0)


    Hello support team,

    After installing the plugin, i get this message on top of the galleries page (admin)

    Thumbnail Generation Alert!
    There is a problem generating thumbnails for your gallery. Please check that your hosting provider has the GD Image Library extension installed and enabled.
    If thumbnails cannot be generated, then full-sized, uncropped images will be used instead. This will result in slow page load times, and thumbnails that do not look correct.

    I have already contacted my hosting company and asked them to check it. The said that the GD Image Library extension is 100% installed and enabled.
    Do you have any idea what could be the problem?

    Thanks,
    Best regards
    Nin0

Viewing 15 replies - 1 through 15 (of 23 total)
  • Hello,
    Just want to ask if i can get some help here?

    Plugin Author bradvin

    (@bradvin)

    hey Nin0 – who do you host through? This could be a permissions issue because the test is done on an image inside the plugins folder.

    Plugin Support phillcoxon

    (@phillcoxon)

    Hi @nin0,

    We haven’t heard back from you so will assume that you have fixed this issue and we can mark this support request as resolved.

    If you have any more questions relating to this issue please reply and let us know.

    Hi,

    It’s not fixed yet. I have checked the permissions on my site and they are correctly configured. I’ve contacted my host and they say that on their side all settings are correct and that it could be a problem with the plugin.
    They gave me these settings
    PHP version : 7.2.12
    PHP GD : Loaded (V2)
    PHP Open SSL : Loaded
    PHP HTTP Wrapper : Found
    PHP HTTPS Wrapper : Found
    HTTPS Mismatch : None
    PHP Config[allow_url_fopen] : 1
    PHP Config[allow_url_include] : 1

    So I’m not sure how to solve this issue.

    Plugin Support phillcoxon

    (@phillcoxon)

    Thanks for replying. We’ve had no other reports of this issue that I’m aware of so it very much sounds like it may be something to do with your web hosting.

    Would you please send an email to support.foogallery@fooplugins.com and include the URL to this support ticket in that email:

    https://wordpress.org/support/topic/thumbnail-generation-alert-3

    I’ll then work directly with you to see if we can identify what is happening and get it resolved for you.

    Plugin Author bradvin

    (@bradvin)

    hi – there next version which is being released very soon will change the thumbnail generation to use a media library image rather than the image in the plugin, to try and eliviate this error from showing

    Hi,
    I also experienced this same error and I am on Pressable hosting. They said the way the plugin is calling for a specific file is not compatible with their platform. They resolved the error for me by changing a function in wpthumb.php on line 85.

    They changes this:

    private static function get_home_path() {
    return str_replace( str_replace( home_url(), '', site_url() ), '', ABSPATH );
    }

    To this:

    private static function get_home_path() {
    return str_replace( 'wp-content', '', WP_CONTENT_DIR);
    }

    Hope this is helpful.

    I am having the exact same problem. I have GD fully installed and functioning however I too get this error. I tried the above and that didn’t fix it for me. I made sure the permissions for uploads was set correctly as well. Below is my system info.

    FooGallery version : 1.6.7
    WordPress version : 4.9.8
    Activated Theme : Publisher Child Theme
    WordPress URL : https://www.omited.
    PHP version : 7.0.33
    PHP GD : Loaded (V2)
    PHP Open SSL : Loaded
    PHP HTTP Wrapper : Found
    PHP HTTPS Wrapper : Found
    HTTPS Mismatch : None
    PHP Config[allow_url_fopen] : 1
    PHP Config[allow_url_include] : 1
    Extensions Endpoint : https://raw.githubusercontent.com/fooplugins/foogallery-extensions/master/extensions.json?v=n7r0GccMICVu
    Extensions Errors : Nope, all good
    Extensions :
    Extensions Active : Array
    (
    [0] => default_templates
    [1] => foobox-image-lightbox
    [2] => albums
    [3] => foobox
    )

    Gallery Templates : Array
    (
    [0] => default
    [1] => image-viewer
    [2] => justified
    [3] => masonry
    [4] => simple_portfolio
    [5] => thumbnail
    )

    Lightboxes : Array
    (
    [foobox] => FooBox
    [dfactory] => Responsive Lightbox by dFactory
    )

    Settings : Array
    (
    )

    Active Plugins : Array
    (
    [0] => foogallery/foogallery.php
    [1] => acf-field-date-time-picker/acf-date-time-picker.php
    [2] => acf-repeater/acf-repeater.php
    [3] => admin-menu-editor/menu-editor.php
    [4] => advanced-custom-fields-pro/acf.php
    [5] => amr-shortcode-any-widget/amr-shortcode-any-widget.php
    [6] => archives-calendar-widget/archives-calendar.php
    [7] => block-specific-plugin-updates/block-specific-plugin-updates.php
    [8] => cms-tree-page-view/index.php
    [9] => compact-archives/compact.php
    [10] => conditional-menus/init.php
    [11] => contact-form-7-honeypot/honeypot.php
    [12] => contact-form-7/wp-contact-form-7.php
    [13] => content-aware-sidebars/content-aware-sidebars.php
    [14] => enhanced-text-widget/enhanced-text-widget.php
    [15] => events-manager/events-manager.php
    [16] => feedzy-rss-feeds/feedzy-rss-feed.php
    [17] => foobox-image-lightbox/foobox-free.php
    [18] => js_composer/js_composer.php
    [19] => leaflet-maps-marker-pro/leaflet-maps-marker.php
    [20] => mailchimp-for-wp/mailchimp-for-wp.php
    [21] => mc4wp-premium/mc4wp-premium.php
    [22] => mp3-jplayer/mp3jplayer.php
    [23] => responsive-lightbox/responsive-lightbox.php
    [24] => tag-groups-premium/tag-groups-premium.php
    [25] => types/wpcf.php
    [26] => wp-miniaudioplayer/miniAudioPlayer.php
    [27] => wp-polls/wp-polls.php
    )

    I was able to resolve my issue by going to settings, images, Run Tests, it came back green and good, I then clicked save settings and the GD error went away.

    Not sure if this will solve everyone’s problems, but in my case it was enough to clear the cache. FooGallery/Settings and hitting the clear cache buttons.

    Thanks again Phill for this tip!
    Best regards

    I also have the same issue and i am unable to resolved, i have also confirmed the GD library is installed and also cleared all caches.

    When i ran the tets in foo gallery i got:

    Thumbnail generation test failed!object(WP_Error)#3919 (2) { [“errors”]=> array(1) { [“invalid_image”]=> array(1) { [0]=> string(21) “File is not an image.” } } [“error_data”]=> array(1) { [“invalid_image”]=> string(82) “http://customconcept.ca/wp-content/uploads/2018/06/CUSTOMCONCEPT_LOGO_FULL-web.png” } } array(2) { [“ext”]=> string(3) “png” [“type”]=> string(9) “image/png” }

    Please help

    • This reply was modified 1 year, 2 months ago by akirastudio.

    I am also having the same problem and the similar error message and the post above

    Please advise solution

    Thanks,

    I’m having a similar problem; I phoned WP Engine support and they confirmed that the GD Library is, indeed, installed (GD library Version 2.2.5) … Interestingly, the Thumbnail Generation Test fails on LIVE, but passes on the STAGING version of the site, running the same version of FooGallery. Could the CDN (CloudFlare) have anything to do with this? I can’t think of much else that is different. I tried clearing both the HTML and CSS caches under the FooGallery Settings > General tab, but neither helped.
    LIVE:
    Thumbnail generation test failed!object(WP_Error)#2660 (2) { [“errors”]=> array(1) { [“file-not-found”]=> array(1) { [0]=> string(0) “” } } [“error_data”]=> array(0) { } } array(2) { [“ext”]=> string(3) “jpg” [“type”]=> string(10) “image/jpeg” }
    Test to see if FooGallery can generate the thumbnails it needs.
    STAGING:
    Thumbnail generation test ran successfully.
    Test to see if FooGallery can generate the thumbnails it needs.

    Please advise. THANKS! 🙂

    Plugin Author bradvin

    (@bradvin)

    @brucerawles – please try enabling the FooGallery setting “Override Thumb Test” under the advanced tab

    Thanks for that suggestion. I just tried it … no change (still getting the same “Thumbnail Generation Alert!” error; so I cleared by (Chrome) browser cache, deleted the Autoptimize cache, and tried toggling and saving the changes for the FooGallery Settings > Advanced > Override Thumb Test checkbox again… Still seeing the error… Any further suggestions? … Thanks in advance!

Viewing 15 replies - 1 through 15 (of 23 total)
  • You must be logged in to reply to this topic.