Support » Plugins and Hacks » Thumbnail Failure in Nextgen Gallery

Thumbnail Failure in Nextgen Gallery

  • When I attempt to create thumbnails for a gallery, I get the following:

    # ID 32: A failure occurred
    [object XMLHttpRequest]

    There does not seem to be any more information available. Clicking on “[more]” just returns to the gallery page.

    wp-content\gallery and all subfolders are 777. This is with a fresh install of v1.0.0 beta 2.

    Any thoughts?

Viewing 15 replies - 1 through 15 (of 25 total)
  • Which browser do you use ? Please open a bug issue here

    I am getting the same error.

    I tried uploading 4 new images to a gallery and it successfully created a thumbnail for the last file I uploaded but it failed on the 3 others. I tried deleting the images and uploading again and failed again.

    I am using WP 2.7 RC2 and NextGen 1.0.0 RC2.

    Just noticed that 3 files that failed were landscape ones where as the portrait oriented image successfully had a thumbnail created. All were 800×600 (or 600×800 in the portrait’s case).

    All fixed!

    I found in the bug report list at the link above that someone recommended that using PHP5 instead for 4 would resolve this issue. My 1&1 server was running 4.4.9 and so I added a .htaccess file and forced it to use PHP5 (5.2.6 is running now) and everything works great. All the thumbnails that failed earlier are now created. This is what I added to my .htaccess file:

    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php

    Too easy!

    Hmm, already running php 5 and that htaccess trick just crashes the entire blog.. Off to look for another solution

    netflow – please post anything you find here. i’m having the same problem.

    Same issue here – 1&1 server, no thumbnails, only large images showing. caringforapathy’s solution worked for me, too – adding a .htaccess-file forcing php 5 did the trick. Nothing else crashed or looks wrong now…

    Thanx , many greetings from Germany – Gabi

    Hi! I have the same problem! I’m using 1and1 server.
    Please can anybody explain step by step the “.htaccess” thing, i have no idea how to do it.


    It’s an issue with 1and1 and not having PHP 5 as the default install.

    Adding the two lines to your .htaccess file will fix the problem. With the new lines in my .htaccess file I have no errors, without it the errors come back.

    It is a very confusing problem with 1and1 as it acts as if it is a permissions issue but it’s not.

    For step by step…

    The way I do it is to show hidden files in my FTP program (currently using Transmit on Mac). I then right click to edit my .htaccess file using what ever text editor I have available. Simply add the two lines:

    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php

    I pasted them in the top of the file.

    Save file and do a refresh of the overview page for the Gallery. It should now show you are using PHP Version 5.2.6 in the info area.

    I have tested this tonight and without running PHP5 this plug-in and several others have issues on 1and1.

    I have submitted a ticket to 1and1 about this, but adding the handler and type to the file works just fine.

    Thanks for your instructions! I have no luck with that, i’ve created the .htaccess y the “Blog” folder of my site and the NextGen Gallery Overview says Version 5.2.6 but thumbnails not working!

    1 and 1 uses shared storage…sometimes it works and if there is not enough memory you get this

    Fatal error: Out of memory (allocated 33030144) (tried to allocate 3072 bytes) in /homepages/5/d187830993/htdocs/tlb/blog/wp-content/plugins/nextgen-gallery/lib/gd.thumbnail.inc.php on line 183

    I really need to find another host or upgrade…this sucks

    thanks so much caringforapathy and Dyno223! that worked like a charm for me!

    Also had the thumbnail problem using nextgen gallery on a 1&1 hosted site. Added the 2 lines as recommended via .htaccess and it worked…..for awhile. Then, it stopped working. Checked .htaccess — and the change was overwritten – reverted to original settings. For this to work, must WordPress core files be installed in a sub-directory and not root? Not understanding why the .htaccess file got overwritten otherwise.

    when the .htaccess file had the 2 lines added, was unable to access newly created pages – ‘received Error 403 – Forbidden’ errors. so guess there’s 2 problems. ugh.

    when I added the two lines to my htaccess file, IE would then ask me to open/save/cancel any attempt to open a php url.

    However in my host’s cpanel php config I was able to switch to version 5. I verified this by reloading the nextGen overview page which lists php v 5.2.8

    Still receiving errors when trying to generate thumbnails of 1000 pixel wide landscape photos. Many – but not all. Could this be related to size of the image (filesize – not dimensions) ?

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘Thumbnail Failure in Nextgen Gallery’ is closed to new replies.