WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Thumbnail Dimensions When Using BPTPI plugin

[Resolved] Thumbnail Dimensions When Using BPTPI plugin

  • Seahawksean
    Member

    @seahawksean

    I just activated your plugin and tried reloading new photos into previously existing Products I had made prior to activating your plugin. When it’s activated it seems to override the WP thumbnail sizes I set in Dashboard > Settings > Media. I have all my thumbnails set to be square (200×200). However, after activating the plugin and I upload a new image into the Product page, and thus media library, it displays the full image instead of the 200×200 thumbnail. Is this plugin supposed to override the WP thumbnails I set myself?

    Thank you in advance.

    http://wordpress.org/plugins/bulk-photo-to-product-importer-extension-for-woocommerce/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author The Portland Company
    Participant

    @d363f86b

    BPTPI doesn’t override any WordPress settings, so I don’t believe this is related to it. However, I believe WooCommerce overrides those settings, so I’d suggest reposting this in their forums.

    Thanks for using our Plugin!

    Seahawksean
    Member

    @seahawksean

    It’s not Woocommerce that’s overriding the WP thumbnail settings because, 1) they are the same and 2) my thumbnail settings in Woocommerce are hard crop for square thumbnails (150×150, 200×200, and 300×300).

    But when I activate use BPTPI to import my images and thumbnails are generated they maintain the original ratio of my images. For example, if I use an image that is 2000x2895px it generates a thumbnail that is 200x290px (rectangular).

    I then deactivate BPTPI and uploaded the same image just using Woocommerce it generates the desired sized thumbnail (square). That would indicate that BPTPI is overriding the Woocommerce/WP thumbnail settings.

    I’ll give this another try and see if I can replicate this problem and follow up with the result here.

    Seahawksean
    Member

    @seahawksean

    Interesting. I tried to upload an image using BPTPI and had the same issue. My thumbnails were not being hard cropped. Then I noticed there was an update for BPTPI ver 3.1.19. I initiated the update it and now all of a sudden it’s generating the thumbnails to the size I want (square). Sweet!

    Now, to figure out how to remove the BPTPI watermark.

    Plugin Author The Portland Company
    Participant

    @d363f86b

    Glad to hear it resolved itself for you. The updated wasn’t related to that but you’re the second person to have mentioned an issue we hadn’t heard before and that the latest update fixed it. I’m certain it’s not possible our updates fixed it unless you were using a very outdated version of BPTPI, in which case that would definitely be possible.

    Either way, glad to hear it’s resolved!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] Thumbnail Dimensions When Using BPTPI plugin’ is closed to new replies.