WordPress.org

Forums

Easy Image Gallery
[resolved] Thumbnail are original size (6 posts)

  1. Beormalte
    Member
    Posted 1 year ago #

    No matter what I do, I am not getting a thumbnail size version in my template.

    In media setting I have 300,
    and I am not overwriting it in my functions.

    What am I doing wrong?

    `<?php get_header(); ?>
    <div id="bg-wrapper" class="clearfix">

    <?php if (have_posts()) : ?>

    <section class="white-bg clearfix extra-height">
    <div class="wrapper">
    <div class="grid collapse-phone">
    <?php while (have_posts()) : the_post(); ?>
    <div class="hero clearfix action fit-text logo-bg">
    <h1 class="med"><?php the_title(); ?></h1>
    </div><!-- /hero -->
    <?php if ( has_post_thumbnail() ) : ?>

    <div class="col-1-4 thumbnail">
    <?php the_post_thumbnail(); ?>
    </div>
    <div class="col-3-4">
    <?php the_content(); ?>
    </div>
    <?php else: ?>
    <div class="small-panel">

    <?php the_content(); ?>

    </div><!-- /sm -->
    <?php endif; ?>
    <?php endwhile ?>
    <?php if( function_exists( 'easy_image_gallery' ) ) : ?>
    <div class="gallery clearfix">
    <h2 class="large-type">Bildergalerie</h2>
    <?php echo easy_image_gallery(); ?>
    <?php endif; ?>
    </div><!-- /gal -->
    </div><!-- /grid -->
    </div><!-- /wrap -->
    </section>
    <?php endif ?>

    </div><!-- /bg -->
    <?php get_footer(); ?>

    http://wordpress.org/plugins/easy-image-gallery/

  2. Andrew Munro (sumobi)
    Member
    Plugin Author

    Posted 1 year ago #

    What size are you getting if you aren't getting the thumbnail size? can I see a live URL? Is 300px what you have set the thumbnail size to? Have you regenerated your images after changing the pixel value?

  3. Beormalte
    Member
    Posted 1 year ago #

    I am not sure what my client did. But if I add new gallery from scratch, it seems to work.
    So what do you think happened to the image sizes, the original sizes are up to 3000px wide

  4. Andrew Munro (sumobi)
    Member
    Plugin Author

    Posted 1 year ago #

    If you change the image sizes in settings > media, your images aren't all automatically resized. You need to regenerate them using one of the plugins available. New images however take on the new sizing. Does this sounds like what is happening?

  5. Beormalte
    Member
    Posted 1 year ago #

    Well when I handed the site over to the client to fill content, it was working fine. So I tested a post with my own images again, and it works. But when I use the 3meg images from the client, it fails to produce a thumbnail.
    So I am thinking the images from the client are too large, and WP could be having issues with it. I just got an error report in the media uploader. So I am thinking its corrupted images?

    http://fuereinander-erkrath.de/Fuereinander_e.V./projekte/donnerstag/

  6. Andrew Munro (sumobi)
    Member
    Plugin Author

    Posted 1 year ago #

    I'm not sure, but I'd be interested to hear what the problem was when you find out. What was your error in the media uploader?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.