Support » Plugin: NextGEN Gallery Image Chooser » Thumb id shortcode gets changed and fails to work

  • I have been using the image chooser to insert thumbs into posts and pages, returning a shortcode like this:

    [thumb id=16142,16143,16144,16145,16146,16147]

    Recently, when saving a post, or even when switching between text and visual mode, the shortcode changes into this.

    <img src="https://myfakeurl.com/wp-content/plugins/nextgen-gallery-image-chooser/images/ngg_placeholder_image.jpg" alt="16142,16143,16144,16145,16146,16147" />

    This happens all over the place, on two websites. The shortcode above works, but I will have to make sure it has not changed before I publish a new post or republish an old post.

    Has this something to do with old (legacy) Nextgen Gallery shortcodes? I can’t figure out what changes in settings I have made to cause this error.

    Let me also add that this (and switching between text and visual view) all too often causes the rendering of the page to halt – it goes into a spin and refuses to respond.

    • This topic was modified 7 months, 2 weeks ago by  sandalsand.
    • This topic was modified 7 months, 2 weeks ago by  sandalsand.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author umertin

    (@umertin)

    It seems that with the new NG-Gallery-Version (3.1.1) the support for legacy shortcodes is broken. I just tried inserting thumbnails with an older version (probably 3.0.16) and the shortcode was converted just fine between text and visual mode. After upgrading to 3.1.1. I experienced the same issues like you.

    I will see if I can do anything by upgrading the javascript of the plugin, but I don’t know when I will find the time to do so.

    I also thought of switching to the new ngg-tags, but there the same applies.

    I would sincerely hope you would find the time to fix this. After so many years NGG Gallery is still hopeless in terms of inserting images into posts.

    Their own shortcode is way to useless:

    [ngg_images gallery_ids="1" image_ids="3,4,5" display="basic_thumbnail" template="default"]

    In addition they are still using this exclusion function, instead of inclusion.

    Good luck !!

    Plugin Author umertin

    (@umertin)

    It turned out that I could free some time right now and I think I found a quick fix. I could only test it briefly, but in my environment (WP 4.9.8 / NGG 3.1.1) the new plugin version (1.1.1) seems to work again.

    The fix probably isn’t backward compatible with older WP/NGG versions, but as it’s recommended to use the latest version anyway for safety reasons, this shouldn’t be an issue, in my opinion. 🙂

    Unfortunately no.

    I updated the plugin and tried it on several posts on two sites. To no avail. There is a hickup where the visual display mode still returns the transfer into a new code, like I included above. In most instances it goes into orbit and refuses to show the editable post.

    Other suggestions?

    Plugin Author umertin

    (@umertin)

    Strange, I just checked again and found no problem with the plugin.

    Are you sure that you don’t use an old version from the cache of your browser (I had this problem yesterday)? I would recommend trying another browser or clearing the browser cache.

    Looks like you’re right. Thank you.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Thumb id shortcode gets changed and fails to work’ is closed to new replies.