Support » Plugin: Yoast SEO » Throwing 400 Bad Request error in 3.6

  • Resolved Michael

    (@michaelhpdx)


    Hi there.

    The wordpress-seo plugin on my site appears to be making the following HTTP request which is throwing an error in my logs. This is recent, but not sure which version it started with (I have wordpress-seo version 3.6)

    HTTP Request:
    POST (Certificate verification disabled: sslverify=false) https://accounts.google.com/o/oauth2/token

    Response: 400 Bad Request

    Stack trace:

    WP_Http->post()
     wp-includes/class-http.php:576
    wp_remote_post()
     wp-includes/http.php:187
    Yoast_Google_WPIO->makeRequest()
     wp-content/plugins/wordpress-seo/vendor/yoast/api-libs/google/io/Google_WPIO.php:95
    Yoast_Google_OAuth2->refreshTokenRequest()
     wp-content/plugins/wordpress-seo/vendor/yoast/api-libs/google/auth/Google_OAuth2.php:268
    Yoast_Google_OAuth2->refreshToken()
     wp-content/plugins/wordpress-seo/vendor/yoast/api-libs/google/auth/Google_OAuth2.php:246
    Yoast_Google_Client->refreshToken()
     wp-content/plugins/wordpress-seo/vendor/yoast/api-libs/google/Google_Client.php:297
    Yoast_Api_Google_Client->refresh_tokens()
     wp-content/plugins/wordpress-seo/vendor/yoast/api-libs/class-api-google-client.php:192
    Yoast_Api_Google_Client->__construct()
     wp-content/plugins/wordpress-seo/vendor/yoast/api-libs/class-api-google-client.php:47
    WPSEO_GSC_Service->set_client()
     wp-content/plugins/wordpress-seo/admin/google_search_console/class-gsc-service.php:159
    WPSEO_GSC_Service->__construct()
     wp-content/plugins/wordpress-seo/admin/google_search_console/class-gsc-service.php:29
    WPSEO_Config_Component_Connect_Google_Search_Console->__construct()
     wp-content/plugins/wordpress-seo/admin/config-ui/components/class-component-connect-google-search-console.php:22
    WPSEO_Configuration_Components->__construct()
     wp-content/plugins/wordpress-seo/admin/config-ui/class-configuration-components.php:21
    WPSEO_Configuration_Service->set_default_providers()
     wp-content/plugins/wordpress-seo/admin/config-ui/class-configuration-service.php:51
    wpseo_init_rest_api()
     wp-content/plugins/wordpress-seo/wp-seo-main.php:283
    do_action('init')
     wp-includes/plugin.php:524


    Cheers.
    Michael

Viewing 5 replies - 1 through 5 (of 5 total)
  • Fatal error: Class ‘Yoast_Google_WPCache’ not found in /srv/bindings/ec376baa811941bbbc062812b8c7569b/code/wp-content/plugins/wordpress-seo-premium/vendor/yoast/api-libs/google/Google_Client.php on line 90

    Plugin Support amboutwe

    (@amboutwe)

    Sometimes strange behavior may be caused by a plugin or theme conflict. The fastest way to rule out conflicts is to deactivate all non-Yoast plugins and switch to a standard theme like Twenty Sixteen. If this resolves the issue, you have a conflict and should activate one plugin at a time until you locate the conflict. Finally, after all plugins are active, switch to your theme. This will narrow down the conflict to a specific plugin or theme.

    If you are unfamiliar with checking for conflicts, we wrote a small guide that will walk you through the steps. You can find it here: How To Check For Plugin Conflicts

    I keep getting this tyyed what you asked it’s not anything but
    Fatal error: Class ‘Yoast_Google_WPCache’ not found in /srv/bindings/ec376baa811941bbbc062812b8c7569b/code/wp-content/plugins/wordpress-seo-premium/vendor/yoast/api-libs/google/Google_Client.php on line 90

    Please fix tried all plugins & theme it is only WordPress SEO Premium

    I’m getting the same issue as Michael and Blurprint. It’s there if I deactivate everything except Yoast. Please advise as this is crippling my site.

    Same issue here. It gives me the same 400 Bad request error.

    (Certificate verification disabled: sslverify=false)
    https://accounts.google.com/o/oauth2/token

    I hope this resolve soon.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Throwing 400 Bad Request error in 3.6’ is closed to new replies.