WordPress.org

Support

Support » How-To and Troubleshooting » Three problems with established WordPress install

Three problems with established WordPress install

  • I’ve been running WordPress at http://www.drewvogel.com since June 2005 on my FC5 box but since installing 2.0.4 I’ve been having trouble in the following areas:

    1. The ability to post comments seems to have disappeared. If a user visits a single-view page, the comments dialog … just isn’t there. Even for me as admin, it’s not there.

    2. I’ve got my Permalinks set to Custom and “/index.php/%year%/%monthnum%/%day%/%postname%/”. As long as I do not visit Options->Permalinks, my site functions as expected. However, if I visit Options->Permalinks, my site’s permalinks stop functioning unless I set them to the default (I don’t even have to click “Update Permalinks Settings”; just visiting the page breaks it), which breaks internal links in my site. This is 100% reproducable.

    I’ve replaced the classes.php and functions_post.php files with the latest copies in this thread (http://wordpress.org/support/topic/54340/page/2?replies=52) and done all the steps here: codex.wordpress.org/Permalinks#Fixing_Permalink_Problems . I’ve followed all the steps on http://codex.wordpress.org/Permalinks#Fixing_Permalink_Problems , but my .htaccess is still never updated.

    3. I’ve got WP-Cache (2.0.17) installed on my machine, but I’m not sure if it’s working or not. From Ricardo’s documentation and my own previous experience, I expect that WP-Cache adds two lines to the bottom of cached pages: “This first time WP-Cache will add a line with the total time needed to create the page, if the page is directly served from the cache, it adds a second line telling it was served from cache.”. However, on my site, only the first line is added (“<!– Dynamic Page Served (once) in 0.484 seconds –>”), but the second line is never added and the cached pages just pile up in /wp-content/cache.

    These are extremely frustrating issues! Can anyone help with any of them? Thanks in advance!

Viewing 15 replies - 1 through 15 (of 32 total)
  • Getting 100% packet loss on drewvogel.com…

    Please try again…

    Nope. Tell your sister to get off the phone ;’)

    heh. I just checked it a moment ago, and it’s up (it wasn’t, but now it is). Please try again, and thank you for your patience!

    Nope… Three strikes.

    That’s really strange.

    Within the last three minutes:
    * I’ve clicked it from the link above and it worked.
    * I’ve opened a browser and cut-and-pasted it from above and it worked.
    * I’ve gone to BabelFish (http://babelfish.altavista.com/) and translated it and it worked.

    It’s working on my end… Could it be something on your end?

    Could be, ’cause it’s loading fine for me…. of course, I have no knowledge of your problem or how to fix, so I’m fair useless…

    Loads fine now…

    1) Says “Sorry, the comment form is closed at this time.” Check settings in Options:Discussion and under Membership in Options:General…

    Ack, I’m late ;’) 2) index.php should not be in a custom permalink. If it’s required, something’s broken.

    3) Go to Options:wp-cache and scroll down, click the list pages button. Might help comfort-level.

    Thanks for checking it out. I’m glad you were finally able to get through.

    1. I checked settings in Options->Discussion. I’ve got the top 6 items checked and made no changes there. Under Options->General, ‘Anyone can register’ and ‘Users must be registered and logged in to comment’ were both UNCHECKED (I seem to recall a security scare that instructed us to UNCHECK ‘Anyone can register’. Has that storm blown over with 2.04?). I CHECKED them both and saved. Now when I log out and visit an article on my site, the comment form displays.

    2. Ever since I’ve run WP, I’ve had to have index.php in my permalink. It’s described as “Almost Pretty” on this page: http://codex.wordpress.org/Using_Permalinks. I would dearly love to fix it so I didn’t have to have index.php in my permalink (in addition to the larger goal of making it so that when I visit Options->Permalinks my site doesn’t bomb). If you’ve got suggestions on either of those issues, I’d appreciate hearing them!

    3. I believe that the cache pages are being created with each visit to the front page but are not being served from the cache for some reason. Please view the source of my front page and see if you see two WP-Cache lines at the very bottom… I only ever see the line telling me that it’s been created (“<!– Dynamic Page Served (once) in 0.484 seconds –>”)

    1) Strange. When you get a chance, test that behavior in another theme?

    2) Re-read http://wordpress.org/support/topic/58389?replies=7 , it looks like you were almost there…

    3) <!-- Dynamic Page Served (once) in 0.513 seconds --> The way wp-cache comments in the source was changed, it no longer does a unique comment if delivering an already-cached page. Check the author’s page: http://mnm.uib.es/gallir/wp-cache-2/

    Thanks for your reply. I appreciate your time and effort!

    1. Yes. I’ll try it in another theme when I get to the office this morning. The comments form was appearing when I went to bed last night but this morning (with no configuration changes or anything), they’re not working again.

    2. I’ll go through all the steps in that link again and let you know!

    3. From the author’s site, under the heading ‘How can I tell if it’s working’ it says, “This first time WP-Cache will add a lines with the total time needed to create the page, if the page is directly served from the cache, it adds a second line telling it was served from cache.” Perhaps I’m misunderstanding it or you’re reading a different place on the site, but from that, it sounds like it adds two lines under correct operation.

    I quickly tried switching to another theme (WordPress Default 1.6, Sandbox 0.6.1, and Tarski 1.1.3) and the comments form still did not appear. I’ve restored it to my original theme.

    (Note that the very first article, “QuickLinks: Articles You’re Here For” does not allow comments. This is by design.)

    From the author’s site, under the heading

    Yes, but if you read the comments, you’ll see he removed the latter one for performance reasons.

    Going to http://www.drewvogel.com/index.php/2006/08/17/system-strangeness/#respond I see a comment form (attractive, btw ;’), but when I submit my comment, I get “Sorry, you must be logged in to post a comment.”

    Thank you for your time and reply! I really appreciate your assistance.

    AH! Thanks for pointing out that the author of the cache removed the second line for performance reasons. I missed that in the comments. I guess it’s resolved, and I can strike it from my list of issues. Thank you for helping me to understand!

    Regarding the comments — I think I discovered something… The comment form displays in Firefox but not in IE. In IE, the comment form doesn’t display, no matter if I click the article title from the front page or the link you sent above. From the same computer using Firefox, the comment form displays properly.

    I’ll work on the permalink thing a bit more this morning once my office calms down.

Viewing 15 replies - 1 through 15 (of 32 total)
  • The topic ‘Three problems with established WordPress install’ is closed to new replies.