Support » Plugin: BackWPup - WordPress Backup Plugin » Three backups in a row instead of one

  • Hi, BackWPup worked with no problem for several years. Since some days I have a problem.
    The job is scheduled to run once every night at 3am in the morning. Now it it running at 3am and then two more times directly after. So now I have three backups instead of one. The logs show no problem. What can I do?

    Thanks
    Chris

Viewing 15 replies - 1 through 15 (of 30 total)
  • Plugin Author Brandon Olivares

    (@cocreation)

    Hi @cpm9, what time is it running for the other times it runs after 3AM? Is it the same time each day or does it differ?

    Hi,

    I have the same problem. In my case, the backup is duplicated once. It is scheduled for 3 a.m., but since October 10th, ot is being duplicated:

    Oct 10: 3:03am and 3:55am
    Oct 11: 3:00am and 3:55am
    Oct 12: 2:00am and 4:04am
    Oct 13: 3:00am and 4:22am
    Oct 14: 3:01am and 4:14am
    Oct 16: 3:03am and 5:18am
    Oct 17: 3:03am and 5:17am
    Oct 18: 3:03am and 3:15am
    Oct 19: 3:03am and 3:16am
    Oct 20: 3:03am and 3:07am
    Oct 21: 3:03am and 3:33am
    Oct 23: 3:03am and 3:47am

    It is a multisite installation with 2 sites

    Hi, here are the timestamps of the backups, shown in the ?page=backwpuplogs page

    October 23, 2017 at 9:17 am
    October 23, 2017 at 3:43 am
    October 23, 2017 at 3:34 am
    October 23, 2017 at 3:34 am
    October 23, 2017 at 3:23 am
    October 23, 2017 at 3:10 am
    October 23, 2017 at 3:03 am
    October 23, 2017 at 3:02 am
    October 23, 2017 at 3:01 am
    October 23, 2017 at 5:01 am
    October 22, 2017 at 9:01 am
    October 22, 2017 at 5:02 am
    October 22, 2017 at 4:58 am
    October 22, 2017 at 4:19 am
    October 22, 2017 at 4:17 am
    October 22, 2017 at 3:42 am
    October 22, 2017 at 3:26 am
    October 22, 2017 at 3:02 am
    October 22, 2017 at 5:01 am
    October 22, 2017 at 3:00 am

    I’m seeing the same issue (wordpress multisite, 8 sites) since this week: multiple backups are performed without any good reason. I’m backing up to Dropbox.

    See also other reports https://wordpress.org/support/topic/multisite-backups/

    • This reply was modified 9 months, 4 weeks ago by  mamebart.

    My backup also goes to Dropbox – if this is a relevant information.
    Thanks

    Mine goes to email, so destination is not probably the cause

    Joel

    (@joellisenby)

    Getting multiple backups here as well but they don’t stop until the server’s drive is full, even generating smaller backup files as it runs.

    Multisite install.
    Backing up locally and dropbox.
    Over 2GB backup size.

    • This reply was modified 9 months, 3 weeks ago by  Joel.
    Plugin Author duongcuong96

    (@duongcuong96)

    @here,
    This bug is really weird, I can’t even reproduce it, so could anyone here please give us your temporary access to your website to helps us debug this problem? you can drop us your information to support@backwpup.com
    We need a user with BackWPUpAdmin role and FTP access.
    Thanks to anyone for your help!

    Just a quick note on this: when I start the backup job manually, everything is fine (only 1 copy is saved).

    just let the plugin be enabled in the main site only. this issue should be gone then. by now the plugin is NETWORK ONLY.
    I don’t know how, but I disabled the plugin for other blogs except the main site. now there is only one backup at each scheduled run.

    Plugin Author duongcuong96

    (@duongcuong96)

    @aminima,
    Did you use WordPress multisite features?
    BackWPUP is designed to show up only on the MAIN NETWORK SITE in multiple site environment. So you said that you disabled the plugin for other blogs except for the main network site, it seems strange to me.
    Could you please explain it?

    Yes I’m using multisite. It seems strange to mee too! I don’t know why this is happening. there must be something wrong with my plugins, because I’m running my network for more than 8 years, and lots of plugins and settings are included during these years. By the way, I disabled the plugin from example.com/wp-admin/network/plugins.php area, but I saw the plugin is active in each blog!!! so disabled the plugin for each of blogs: blog1.example.com blog2.example.com, except the main blog at example.com.

    This is strange, because I re-enabled/disabled the plugin in network plugins area, and now I cannot enable/disable it in each blog any more. (this is the true behaviour). So this is not the issue, and it’s not related to your plugin.

    BUT if you let users enable/disable BackWPUP for each of their blogs, I think this bug should be gone and everybody would be happy!
    Maybe there is a huge network of blogs, and the admin wants to let users generate backups for their own blogs, indeed with the limitation to their specific database tables and files.

    Me too. Happens on single site. Happens on multisite. Each job runs three times, three duplicate files. Only runs once if run manually. Multisite backup jobs are controlled from the Network Admin dashboard. Each domain is scheduled to backup in turn, separately, at staggered run times. Sql files backed up daily and site files backed up once per week. Backups saved to host, email to me. Flooded with emails for quite some time. Hoped an update would clear it up but this is happening too long.

    My settings retain a given number of backup files. Today I wanted to restore from a files backup. With so many multiples of each backup, all my “files” backups had been flushed away except one, thankfully the one I needed!

    Will try deactivating/activating the plugin as above, will report back if it works.

    • This reply was modified 9 months, 2 weeks ago by  wilderbee.

    https://wordpress.org/support/topic/multisite-backups/

    in the topic above, the plugin author suggests to change the type of wpcron job…

    @mamebart, it did not help. On multisite, enabling Alt Cron per link above resulted in no backups at all (there should have been two). Alt Cron now disabled, I will try bumping up the settings for Max No Retries and Max Script Execution Time.

Viewing 15 replies - 1 through 15 (of 30 total)
  • You must be logged in to reply to this topic.