Support » Theme: Twenty Seventeen » threaded comments and page width

  • Hi!

    I thought I had some basic knowledge in CSS, but I am completely lost in this new amazing theme! Therefore I humbly ask for guidance 🙂 I have loads of issues, but these are the most critical.

    First. The comments are supposed to be threaded, but they look like I-donnow-what… a complete mess and it’s impossible to se which comment is an answer to which comment 😮 Is it possible to clean it up?

    Then. Is it possible to under each post get a direct link to the comments? In my old theme I had the regular “this post has been commented on X times” and I miss that.

    Also. I’ve desperately tried to change the width of my blog to fill up as a one-column, but I simply cannot. The word “posts” is impossible to get rid of, and I reckon it could be a clue? On the single posts it looks fine, but in the flow the site divides itself into two columns?

    My address is http://ullrika.se and I really really tried for days, but i realise that google is no longer enough! I have not been able to create a child theme so I carefully work in the stylesheet, custom CSS and plugins.

    Many really thankful regards in advance! I hope someone of you experts can reach out a hand!

    • This topic was modified 3 years, 1 month ago by ullrika.
Viewing 15 replies - 1 through 15 (of 18 total)
  • The width customization has been answered here already https://wordpress.org/support/topic/change-content-and-sidebars-width/ Although that will only adjust your blog page. As for the rest of your requests, I’m not sure. You might be able to hide the page title. You could change the word “posts” to something else by changing the title of the page of your blog entries.

    I really appreciate your help! However, the solution in the linked post does not work for me (I’ve tried it already). If you get the opportunity to quickly take a look at my site you will see what I mean!

    The word (page title?) next to my blog posts is automatic generated and I have no idea where it comes from or how I change it 🙁

    Thanks again for your input! Hopefully, someday I will be able to solve the puzzle!

    It looks like your site is still set on two-columns option. Make sure under “Theme Options” you have selected One Column, and not Two Column. You can still have your blog and have a sidebar, if that’s what you are trying to set up?

    I know! And I do have selected the One Column box! As it is right now it would be better to have the sidebar (which I’ve had for ever but got tired of). However. Even with or without the sidebar I impossibly can change the width of anything on the site! The sidebar vis-a-vis the text content is constant?! 🙁

    I just saw now that you didn’t make a child theme, so are you changing the CSS directly? There might be an issue in that, because your blog is the layout that the two column setting does (not saying you set it on two columnn, but something you changed in the css may have done it). The new WordPress update allows you to put in CSS overrides in the Additional CSS tab on the customization screen, and you should really be doing your overrides there.

    I would restore the stylesheet back to the default and go from there. The main settings you’ll need for the width override you can change in the addition CSS field (I’m doing it with my own site right now http://ajamoore.com ). These are the overrides I used for changing the width, and have had no issues.

    .wrap { max-width: 1150px; }
    .page-one-column .panel-content .wrap {
    		max-width: 1000px;
    	}
    .single-post:not(.has-sidebar) #primary,
    .page.page-one-column:not(.twentyseventeen-front-page) #primary,
    .archive.page-one-column:not(.has-sidebar) .page-header,
    .archive.page-one-column:not(.has-sidebar) #primary {
    	margin-left: auto;
    	margin-right: auto;
    	max-width: 900px;
    }

    The two differences in width are due to some wonky default settings for the blog entries and normal pages have a different setting in the code, for some reason, but this gets the two different types of pages even. Edit the width numbers to your own design.

    But I can’t stress restoring the default style sheet and then doing these changes on the additional css option enough. Once they start updating the theme, you’re going to have even more issues if you don’t.

    • This reply was modified 3 years, 1 month ago by ajadraws.
    • This reply was modified 3 years, 1 month ago by ajadraws.

    I’m so thankful for your help! (I checked your page and it’s wonderful!)

    The thing is though, the style sheet is in default mode. It’s true I don’t have a child theme, but also I haven’t saved any changes in the style sheet! I’ve definitely tried to make changes, but since nothing has worked I carefully restored everything back right away.

    I tried your code in the Additional CSS but nothing happens. It all looks the same. It’s like something really weird is going on!!? On your site it looks like you’ve managed to create a page with your blog, maybe that’s the key? I have tried that too (used google as tutorials) but don’t know how to do it 🙁

    I am really so thankful for your guidance! Just so sorry nothing seems to work.

    In fact, the code works fine.

    .wrap { max-width: 1150px; }
    .page-one-column .panel-content .wrap {
    		max-width: 1000px;
    	}
    .single-post:not(.has-sidebar) #primary,
    .page.page-one-column:not(.twentyseventeen-front-page) #primary,
    .archive.page-one-column:not(.has-sidebar) .page-header,
    .archive.page-one-column:not(.has-sidebar) #primary {
    	margin-left: auto;
    	margin-right: auto;
    	max-width: 900px;
    }

    Paste it into Additional CSS -> Save Changes -> Clean your cache and load the page.

    It works to me. Thanks @ajadraws !

    By the way, I hate how new theme show the entire post content. Do you know how to load only excerpt or a short description?

    I’m so happy it works for you Arutam! As you can see if you visit my website it doesn’t for me, no matter how many times I restore the theme and clean my cache 🙂 I suppose I just have to live with the flaws.

    Thank you for this fix for widening pages!! I was tearing my hair out trying every combination in my stylesheet (child theme) with no luck. You are my hero 🙂

    @arutam that solutions works great for pages. However, I have a problem on my blog page. It is formatted completely different to the normal pages. Have a look here.

    @ullrika I checked your blog, and it looks you made the code works!?

    @dmweyer what kind of problem?

    Did you leave a link? I dont see anything.

    @arutam, sorry was playing with another theme. I have reactivated twenty seventeen. have a look at my blo4gw page to see what I mean. Will leave that theme live.

    @dmweyer I found an url in your WordPress profile, thats your blog? It shows me a blank page… or how can i find your blog?

    @dmweyer I checked it, but sorry I still dont know what you want.

    Do you want to add a sidebar to your blog section?

    This article could help you:

    https://codex.wordpress.org/Twenty_Seventeen

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘threaded comments and page width’ is closed to new replies.