Support » Plugin: The Events Calendar » Thousands of pages generated after update

  • Resolved azzuwp

    (@azzuwp)


    Hi there,
    after the last update we’ve seen thousands of pages automatically generated by the plugin being displayed in the search results.
    URLs are like:
    domain/?post_type=tribe_events&eventDisplay=day&paged=2&eventDate=2021-04-02
    or
    domain/scadenze/elenco/?tribe-bar-date=2021-07-05&eventDisplay=past

    Through Yoast SEO we’ve excluded tribe_events and tribe_events_cat from search results but it’s not enough. Are there any options I’m not seeing in the settings?

    Everything was fine before. How can we sort this out? Please help

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Ali Darwich

    (@tokyobiyori)

    SUPER-O EL MOPO

    Hello,

    Thanks so much for your message. Just to confirm, this is for your internal site’s search, right? If so, are you using something like Relevanssi or something similar to improve your internal search? How did you identify the pages? With a crawling tool?

    Thread Starter azzuwp

    (@azzuwp)

    Yes, we used a crawling tool. With this we also generate the sitemap which is now populated with loads of useless htmls…

    Thread Starter azzuwp

    (@azzuwp)

    Any ideas how to solve this?
    thanks

    Plugin Support Deblyn Prado

    (@deblynprado)

    Hello there @azzuwp!

    That URLs aren’t really a page “created” by the plugin. This is a search URL that’s being indexed.

    You can remove this from your indexation checking Google Search Console setup and checking if your SEO / Search plugin has some setting available to help you on that.

    Please let us know your findings.

    Cheers,

    Plugin Support Marho

    (@matumu)

    Hi there!

    This thread has been inactive for a while so I’ll be marking it as Resolved.

    Please feel free to open a new thread if any other questions come up and we’d be happy to help.

    Best regards,

    Marho

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.