WordPress.org

Support

Support » Themes and Templates » This works but it de-activates the HTML tab in the edit page page

This works but it de-activates the HTML tab in the edit page page

  • I’m using the Elegant Theme called “Gleam.”

    Here are my goals:
    1) embed a locally-hosted MP4 video
    2) be able to manually modify its size from inside the editor
    3) have it be centered horizontally
    4) have it automatically play when the page is loaded

    Here’s what I’m doing:

    <p style="text-align: center;"><object width="384" height="288"> <embed src="http://mySite/myMP4.mp4" width="384" height="288" autoplay="true" controller="true" type="video/mp4" scale="tofit" pluginspage="http://www.apple.com/quicktime/download/"> </embed></object></p>

    It satisfies all my requirements except number 2. That’s because, for some reason, it disables the HTML tab after I leave the edit page. For example, after I click “update”, and then go to “view page” from the top menu bar, when I go back to “edit page” the HTML tab will be inactive.

    I can see the placeholder of the movie on the View tab, but clicking on the HTML tab does nothing. Literally nothing, as if it’s just another piece of text on the page. If I manually delete the movie placeholder from the View tab, the HTML tab suddenly becomes active again (now that it only shows a blank window).

    Anybody able to help?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Moderator Andrew Nevins

    @anevins

    Forum moderator

    Have you tried contacting the theme’s vendors?

    I’m new at this. How well does that usually work?

    In my experience elsewhere, companies themselves aren’t very helpful, and the forums are where the action is.

    Moderator Andrew Nevins

    @anevins

    Forum moderator

    It is as I suspected. The company is not very helpful. In searching for things like this, the main response seems to be “we can’t help you with that.”

    esmi

    @esmi

    Forum Moderator

    We do not support commercial themes as you paid for support when you bought the theme. It is not our place to keep theme vendors in business.

    I get that, but I wonder if the theme is really the issue here. I’m really just looking for a way to embed mp4 video so that it auto plays and I can set the display size by hand. It’s more an HTML question than anything to do with the theme. I should have just left the theme stuff out of the post.

    Are you good with HTML yourself? If you are, could you glance at the code and tell me if it should be working or not? Or if there’s a better way?

    esmi

    @esmi

    Forum Moderator

    Are you good with HTML yourself?

    Yes but I don’t do site specific work for anyone other than commercial clients. Sorry.

    I’m confused what you’re trying to do. I hope I’m not making you mad. I see lots of other places in these forums where people ask for advice on HTML and people give tips. Are they not supposed to do that? It’s fine if that’s not your thing, but since you’re a moderator it confuses me that you’d pretty much show up and say “you can’t be helped.” Is it that I shouldn’t have mentioned themes? I understand now that themes aren’t really to be brought up here.

    Anyway I’ve found a solution, here it is, for anyone else that’s curious:

    <object width="320" height="240"
    classid="clsid:02bf25d5-8c17-4b23-bc80-d3488abddc6b"
    codebase="http://www.apple.com/qtactivex/qtplugin.cab#version=6,0,2,0">
    <param name="allowFullScreen" value="true" />
    <param name="wmode" value="transparent" /><
    param name="src" value="http://yourSite/yourmovie.mp4" />
    <param name="allowfullscreen" value="true" />
    <param name="controller" value="true" />
    <param name="scale" value="tofit" />
    <embed width="320" height="240" type="video/quicktime"
    src="http://yourSite/yourmovie.mp4" allowFullScreen="true" wmode="transparent"
    allowfullscreen="true" controller="true" scale="tofit" /></object>

    It autoplays, it’s hand-scalable, it’s MP4, and it doesn’t disable the HTML tab.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘This works but it de-activates the HTML tab in the edit page page’ is closed to new replies.
Skip to toolbar