Support » Fixing WordPress » “This Website is Under Construction.” on home page only

  • Resolved edasaki

    (@edasaki)


    My website’s homepage is stuck in an “under construction” state: https://i.imgur.com/6boBQVe.png

    I’ve disabled all plugins in search of the cause, and unfortunately it still persists. I did this because a search seemed to suggest this could be caused by a plugin. I don’t have that many plugins anyways, and none of them are intended to provide some kind of maintenance/coming soon mode.

    I’ve also seen a reference to a maintenance mode in WordPress, where a .maintenance file is created in the root folder. I don’t see this file, and I was able to update some plugins without any issues (they successfully showed the “Disabling maintenance mode” message when the update was done).

    The error icon on this page, error.png, is present in the root folder of the wordpress installation. Combined with the fact that I disabled all plugins, I believe this is something to do with WordPress itself and not a plugin.

    Interestingly, other pages work fine. Only the home page is stuck like this. I can still use the admin panel, and open our pages and posts normally by visiting their URLs. Only the home page with no URL extension (i.e. ending in just / ) has this construction message.

    Any ideas where I can disable this?

    • This topic was modified 2 years, 5 months ago by edasaki.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator

    Please ask your host to check on this.

    Have you tried this with your home page
    go to your theme settings i.e Appearence > Customize >Home Page Settings> Static Front Page > Your front page displays a static page(select Your Home Page as static page)

    OR there can be a option that enables to show this message(This Website is Under Construction) depending on your theme it can be an Option like NOTICE in Appearence > Customize.

    TRY this:)

    Thread Starter edasaki

    (@edasaki)

    Thanks for the suggestion @sarpreets , unfortunately changing the settings for home page continues to show the same page no matter what page/post I set it to. And I don’t see any option for it.

    I will ask my host about this, perhaps they did something.

    Daniel

    (@daniel54210)

    Do you have the root SSH access access to the hosting?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘“This Website is Under Construction.” on home page only’ is closed to new replies.