WordPress.org

Forums

SunRain
this theme doesn't show any thing after activation (27 posts)

  1. azita
    Member
    Posted 10 months ago #

    Hi when I log in wordpress, I can see my page in view page but when I log out, It doesn't show any thing in their place.It seems that I don't have any theme installed in my page.
    Why? What should I do?
    When I ask my host, they said that parsing front-page.php has error ":" in line 27 but I didn't find that.

  2. azita
    Member
    Posted 10 months ago #

    No body answere me?!!!!

    "Hi when I log in wordpress, I can see my page in view page but when I log out, It doesn't show any thing in their place.It seems that I don't have any theme installed in my page.
    Why? What should I do?
    When I ask my host, they said that parsing front-page.php has error ":" in line 27 but I didn't find that."

  3. stephencottontail
    Member
    Posted 10 months ago #

    Can you post a link to your website? Also, can you post the exact error message that your host gave you?

  4. azita
    Member
    Posted 10 months ago #

    Yes, it doesn't show anything just some statements.
    [27-Jul-2014 14:55:03 UTC] PHP Parse error: syntax error, unexpected ':' in /themes/sunrain/front-page.php on line 27[27-Jul-2014 14:55:03 UTC] PHP Parse error: syntax error, unexpected ':' in /themes/sunrain/front-page.php on line 27

  5. azita
    Member
    Posted 10 months ago #

    I contacted my host. They said the problem is with the theme

  6. stephencottontail
    Member
    Posted 10 months ago #

    Did you make any changes to the theme's files? I don't see any ":" on line 27 of that file. Can you post the entire contents of that file to Pastebin and post the link here?

  7. azita
    Member
    Posted 10 months ago #

    No there is no : in my theme too.
    I didn't change any thing.

  8. azita
    Member
    Posted 10 months ago #

    Just I have change something in it's css file.
    When I log in the wordpress every thing looks good
    but when I log out from outside my website goes wrong

  9. stephencottontail
    Member
    Posted 10 months ago #

    Do you still have this problem if you temporarily disable any and all plugins you may be using? If so, try reactivating any plugins one by one and see if the error returns. After doing that, try switching to the default Twenty Fourteen theme and see if the error still persists.

  10. azita
    Member
    Posted 10 months ago #

    http://pastebin.com/ALFgtaLY

    It take a month to change many things in css but doesn't show that

  11. azita
    Member
    Posted 10 months ago #

    I tried changing theme but not plugins

  12. azita
    Member
    Posted 10 months ago #

    but if some plugins were wrong why from login view page it is correct?

  13. azita
    Member
    Posted 10 months ago #

    Now it is blank when I deactivated plugins.

  14. azita
    Member
    Posted 10 months ago #

    When I change the theme every things goes right.

  15. stephencottontail
    Member
    Posted 10 months ago #

    What plugins were you using?

  16. azita
    Member
    Posted 10 months ago #

    But I put all of my time in the sunrain theme

  17. azita
    Member
    Posted 10 months ago #

    many, visual form builder, Newsletter,testimonial,Google Maps Ready,Image vertical reel scroll slideshow,Sliding Social Icons

  18. azita
    Member
    Posted 10 months ago #

    Responsive Admin Maintenance Pro With Countdown

  19. stephencottontail
    Member
    Posted 10 months ago #

    I understand, and I should have been more clear in a previous message. When I asked you to temporarily change your theme and your plugins, I was trying to figure out why everything looked correct when you were logged in, but not when you were logged out. Perhaps to minimize confusion, from this point on we should only discuss your initial parsing problem with the SunRain theme and worry about why your website looks different when you are logged in later.

  20. azita
    Member
    Posted 10 months ago #

    that is blank now

  21. stephencottontail
    Member
    Posted 10 months ago #

    Can you activate the SunRain theme again and all of your plugins you were using? Let's try solving the parsing issue first and worry about why your site looks different when you are logged in later.

  22. azita
    Member
    Posted 10 months ago #

    When I change the theme it shows every thing. Without that every thing is blank. It says no page

  23. azita
    Member
    Posted 10 months ago #

    Yes now my theme is sunrain and plugins are activated but it is blank.

  24. azita
    Member
    Posted 10 months ago #

    I wonder when I am logged in I can see my theme with all plugins.
    But when I signed out from outside There is blank at the same time.

  25. stephencottontail
    Member
    Posted 10 months ago #

    Can you post a link to your website?

  26. azita
    Member
    Posted 10 months ago #

    What do you mean post alink?
    Now I have another problem like this with woocommerce too.
    It doesn't show my products when I log out from wordpress.

  27. stephencottontail
    Member
    Posted 10 months ago #

    It can be easier to help diagnose certain problems if we can see the website in question. You can post a link by using the "Link" button above the posting form.

Reply

You must log in to post.

About this Theme

About this Topic