Support » Plugin: All In One WP Security & Firewall » This site can’t be reached 127.0.0.1 refused to connect.

  • Resolved GunnyRet

    (@gunnyret)


    When All In One WP Security is activated, I am getting “This site can’t be reached
    127.0.0.1 refused to connect”. when trying to login to dashboard.

    When I deactivate, I have no problem accessing dashboard. I have also had other users tell me the same thing when trying to access the login page.

    It would appear that I have inadvertently activated a rule that is blocking folks I didn’t want blocked.

    How do I fix this setting if I can’t access settings through dashboard?

    Thanks in advance!

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 30 total)
  • Plugin Author wpsolutions

    (@wpsolutions)

    Hi,
    Try the following when you have blocked yourself:

    1) use CPANEL file manager (or FTP) and temporarily rename this plugin’s folder.
    eg, rename from
    all-in-one-wp-security-and-firewall
    to
    tmp-all-in-one-wp-security-and-firewall
    2) Get your currently active .htaccess file and remove all code which is between and including the following tags:
    # BEGIN All In One WP Security
    # END All In One WP Security
    3) Log into your site using the standard login link – ie, wp-login.php
    4) Using your cpanel or FTP rename the folder back to all-in-one-wp-security-and-firewall.
    5) Once logged in you can disable or re-configure the feature(s) which were giving you problems

    I may have figured out the issue. aiowps wasn’t listed in the .htaccess file. However, I found a line that somehow inadvertently combined another url I manage:

    RewriteCond %{HTTP_USER_AGENT} ^(.+)$
    RewriteCond %{SERVER_NAME} ^gunnyretneovets\.com$ [OR]
    RewriteCond %{SERVER_NAME} ^www\.gunnyret\.com$

    Naturally, this isnt the entire .htaccess file. I just wanted to give you a snippet of where the error was buried. I’ll have to try to new .htacess from another location, and see if I still have errors.

    Will keep you posted.

    Thanks.

    • This reply was modified 2 years, 2 months ago by GunnyRet.

    Ok. I found an .htaccess file that was recent. It didn’t have any reference to AIOWPS in the code. I was hopeful that it was going to resolve the issue. As soon as I reactivated AIOWPS, it sent me to 127.0.0.1 again.

    I’m not sure where in ALL the various settings this has been messed up. I see there are several settings that may be used to direct users to 127.0.0.1 under certain instances.

    I manage 5 different sites, and this seems to have affected all of them when AIOWPS is enabled. Maybe I should just switch to another security plugin.

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi @gunnyret,

    Ok. I found an .htaccess file that was recent. It didn’t have any reference to AIOWPS in the code. I was hopeful that it was going to resolve the issue. As soon as I reactivated AIOWPS, it sent me to 127.0.0.1 again.

    Try the following steps, see if they help. Deactivate AIOWPS and delete the .htaccess file via FTP while you are logged in. Then navigate to Settings -> Permalinks and click on Save Changes button. This will create a fresh .htaccess file. Once this is done, enable AIOWPS plugin. Let me know what happens.

    Regards

    • This reply was modified 2 years, 2 months ago by mbrsolution.
    Plugin Author wpsolutions

    (@wpsolutions)

    Hi,
    Another thing you can do is to check in your DB.

    Using PHPMyAdmin, find the table called “aiowps_permanent_block”.
    Check if your IP address is listed as a record in that table. If so, delete the record which contains your IP from that table.

    @mbrsolution, Thanks for the suggestions. I deleted the .htaccess file via cPanel. Saved the permalinks and generated a new .htaccess file. On reactivating the plugin, it immediately takes me to 127.0.0.1.

    @wpsolutions, I can go into the tables, and follow your advice. However, I am not the only user affected. One of my customers/clients for our non-profit says when she tries to login, she is getting the same result. This is affecting all my sites.

    Another thing I noticed, is that when I tried to access the login page from a public wifi, I am blocked in the same manner. I CAN login when I get home, but only IF AIOWPS is disabled.

    I am finding “several” instances of .htaccess. May I ask what folder the .htaccess file SHOULD reside? I’m wondering if it is possibly “misfiled”; causing the errors.

    I appreciate both of your suggestions.

    I LOVE AIOWPS, but if I can’t fix this, I’ll have to find another solution. I HAVE to be able to allow my clients the capability to login to create applications to apply for our programs that support employers wishing to hire Veterans.

    One of the things I really use this plugin for is that it allows me to manually approve new registrations.

    • This reply was modified 2 years, 2 months ago by GunnyRet.
    • This reply was modified 2 years, 2 months ago by GunnyRet.

    @wpsolutions, I just checked for that table in PHPMyAdmin, and didn’t see my I.P. address blocked. I believe I have/had my I.P. address whitelisted as well.

    Plugin Author wpsolutions

    (@wpsolutions)

    Hi,

    I am finding “several” instances of .htaccess. May I ask what folder the .htaccess file SHOULD reside?

    The .htaccess file I was referring to earlier will normally be inside the root folder which contains your WordPress installation.

    Sorry for my slow response, @wpsolutions. I tried following your last suggestion by removing the .htaccess and updating permalinks. That still didn’t work.

    During a visit to my client’s office, I tried to mimic her complaint that she couldn’t login. We say a redirected too many times error screen on using the “…wp-login.php”.

    I entered the address with no login command, https://website.org and I was immediately taken to my dashboard and I was logged-in. Next, I tried “…wp-admin and got the same thing. I was logged into the dashboard. This is very troubling.

    I’m currently on my hotspot and cannot access the login page, and tried the steps just described to no avail. Again, I can successfully login to all 5 of my websites when I’m on my home WiFi. I’ve dismissed simply clearing cookies and cache, because my customer’s IT folks did that too and it didn’t help.

    I’ve tried to disable all plugins, or just those that have anything to do with security, or buddypress, and still coming up with nothing. I really hate to pay GoDaddy to fix this!

    Any final clues?

    Plugin Author wpsolutions

    (@wpsolutions)

    Hi,

    I’m currently on my hotspot and cannot access the login page, and tried the steps just described to no avail. Again, I can successfully login to all 5 of my websites when I’m on my home WiFi

    I recommend that you perform some tests to identify which AIOWPS feature (if any) is causing this.

    From the network where you are able to log in to the WordPress admin (ie, your home wifi), start by disabling one AIOWPS feature at a time and then checking to see if that problem goes away by attempting to log in from one of the other networks where the problem occurs. (you might need to co-ordinate with someone when you are doing these simple tests)
    Repeat the above process for every time you disable one of the AIOWPS features and if all of a sudden the problem goes away during one of the steps, then you know that the last AIOWPS feature you disabled was causing the issue for you.
    Let me know how it goes.

    My faithful friend @wpsolutions, I must apologize for my last post. I totally neglected to mention that after I tried your suggested work-arounds, and still seeing errors, I deleted the plugin altogether.

    Even with the plugin removed, I’m still seeing this highly unusual behavior. And, so are my clients.

    I’m going to try copy/pasting my last thread into a new WordPress.org support forum and see if anyone can possibly help me identify the cause of my issue.

    I’m not going to close this out right now. I’ll circle back and let you know if/when the issue has been identified and resolved.

    Thanks again for all your diligence!

    Plugin Author wpsolutions

    (@wpsolutions)

    Hi,

    Even with the plugin removed, I’m still seeing this highly unusual behavior. And, so are my clients.

    This suggests that the aiowps plugin is probably not the cause of your problems.

    hosting y dominio

    (@hostingydominio)

    I confirm that this is not an issue but a feature.
    To replicate:
    When logging in, you write the wrong username
    Then the address bar will change to 127.0.0.1 and a message appears: This site can’t be reached.
    After that you will not able to reach the website even your homepage will turn into 127.0.0.1.
    I tried to reach my homepage through proxy and it was reachable. So that hinted me to an IP block.
    I accessed my folder public_html through cPanel and renamed the all in one plugin to any name (public_html > wp-content > plugins > back-all-in-one-wp-security-and-firewall).
    That deactivated the plugin and I could login.
    Once there I updated the AIOWPS and other plugins.
    Then in the dashboard of AIOWPS I could see that my IP address was blocked. So I unblocked it.
    But why was I blocked? well I did not remember that I put a wrong username and I had this feature of AIOWPS activated: WP Security > User login > Instantly Lockout Invalid Usernames
    This was checked
    After, confirming my failure, I left the option checked.
    This AIOWPS plugin is good and I will donate in 3 months, if it keeps working well.

    Forgive me support forum for it has been MONTHS since I last posted on this topic.

    1. I took a break from this thinking it would help me see things more clearly.
    2. I have been inundated with other business.

    How can I export the settings from another site that is working fine with both AIOWPS and WORDFENCE simultaneously, and then import the AIOWPS settings into the troublesome site in cPanel?
    The troublesome site only fails when I activate AIOWPS. I’ve deleted the .htaccess file and re-saved permalinks to no avail.

    Thank you!

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi @gunnyret, try the following documentation.

    Let me know what happens.

    Kind regards

    • This reply was modified 1 year, 11 months ago by mbrsolution.
Viewing 15 replies - 1 through 15 (of 30 total)
  • The topic ‘This site can’t be reached 127.0.0.1 refused to connect.’ is closed to new replies.