Support » Plugin: Jetpack by WordPress.com » This site cannot be accessed

  • Resolved chrisonline

    (@chrisonline)



    I have connected two WordPress self hosted sites.
    Both are worked fine, but today I see at one site “This site cannot be accessed”.
    The other one is working fine.

    I have disconnected and reconnect the site with the message, but again I see “This site cannot be accessed”!

    Where do I see any more info about this error?
    Can anybody help how I can resolve this?

    FYI:
    Both website on the same provider.

Viewing 15 replies - 1 through 15 (of 19 total)
  • Plugin Support Dat Hoang

    (@htdat)

    Could you post your site URL here, so I can have a look?

    If you want it to remain private, you can also contact us via this contact form:
    Contact Support

    chrisonline

    (@chrisonline)

    Oh sorry forgot to post 🙂

    The working one is http://www.colapps.net and the URL who is not working is http://www.chrisonline.at!

    Plugin Contributor Cena

    (@cena)

    Hi Chris,

    While your site is publicly accessible, we cannot access your site’s XML-RPC file:

    http://www.chrisonline.at/xmlrpc.php

    This file is used by Jetpack and other plugins and apps to connect to your site. It must return the following message:

    XML-RPC server accepts POST requests only.

    You can see a working example here:

    http://jetpack.com/xmlrpc.php

    Since your site returns an error for this page, I would recommend that you check the following:

    1. Can you see the xmlrpc.php file at the root of your WordPress installation when accessing your site via FTP?

    2. Do you use any security plugins that may block access to this file? If so, could you disable them?

    3. Does your hosting provider block access to this file? You may need to contact them to find out.

    Let us know how that goes!

    chrisonline

    (@chrisonline)

    Hi Cena!

    Both links are working.
    If I click on this link http://www.chrisonline.at/xmlrpc.php I get the same as if I click on this link http://jetpack.com/xmlrpc.php!

    On both links I see this text:
    XML-RPC server accepts POST requests only.

    1.
    If I check this file via FTP I see it too:
    xmlrpc

    2.
    No I don’t use any security plugins.

    3.
    I think not because it is accessable via the link above.

    Plugin Support Dat Hoang

    (@htdat)

    Hi there,

    Thanks for your info.

    You can test the following command in your terminal

    curl -A ‘Jetpack by WordPress.com’ -d ‘<methodCall><methodName>demo.sayHello</methodName></methodCall>’ http://www.chrisonline.at/xmlrpc.php/xmlrpc.php

    The result will be 404 – not found.

    I suggest contacting your host to know where the block is. Your host may need the IP ranges for the connection between your site and Jetpack/WordPress.com”

    https://jetpack.com/support/hosting-faq/ – the “Whitelist all communications between WordPress.com and Jetpack”.

    chrisonline

    (@chrisonline)

    OK thanks. I have just contacted my provider.
    So let’s see what they say.

    I will update this thread once I get feedback.

    chrisonline

    (@chrisonline)

    Hi!

    There is a typo in your curl statement.
    Of course you get a 404 back because this does not exist.

    You wrote:
    curl -A ‘Jetpack by WordPress.com’ -d ‘<methodCall><methodName>demo.sayHello</methodName></methodCall>’ http://www.chrisonline.at/xmlrpc.php/xmlrpc.php

    But I think it should be:
    curl -A ‘Jetpack by WordPress.com’ -d ‘<methodCall><methodName>demo.sayHello</methodName></methodCall>’ http://www.chrisonline.at/xmlrpc.php

    Why the double “xmlrpc.php” at the end?

    chrisonline

    (@chrisonline)

    I have just now tried it with curl and this command:
    curl -A "Jetpack by WordPress.com" -d "<methodCall><methodName>demo.sayHello</methodName></methodCall>" http://www.chrisonline.at/xmlrpc.php

    And I get this repsonse back:

    <?xml version="1.0" encoding="UTF-8"?>
    <methodResponse>
      <params>
        <param>
          <value>
          <string>Hello!</string>
          </value>
        </param>
      </params>
    </methodResponse>
    • This reply was modified 10 months ago by  chrisonline.
    Plugin Contributor Cena

    (@cena)

    Chris,

    When I go to http://www.chrisonline.at/xmlrpc.php I’m definitely seeing a 404 error there still.

    You can also see the error in the Jetpack debugger here: https://jetpack.com/support/debug/?url=http://www.chrisonline.at/

    Would you try viewing both of those links in an incognito window, or totally different browser? I wonder if you seeing some cached data.

    Best,
    Cena

    chrisonline

    (@chrisonline)

    I have tried it now on my notebook and on my PC and now on the Smartphone.

    I don’t get the error message.

    And as I wrote also with the curl command it is working on my PC.

    My provider has also wrote that all is Ok on there side.

    Plugin Support Dat Hoang

    (@htdat)

    Hi Chris,

    > Why the double “xmlrpc.php” at the end?

    I replied the wrong link but in general, it’s still the issue here with 404 errors when our WordPress.com servers try to interact with your site via the XMLRPC file.

    This is what you can see from our end.

    Link: http://cld.wthms.co/RtcWrB

    This means your hosting is blocking our IPs to the XML-RPC file. Please double check with them and see if there is any IP in our ranges in their blacklist.

    https://jetpack.com/support/hosting-faq/

    • This reply was modified 10 months ago by  Dat Hoang.
    chrisonline

    (@chrisonline)

    Thanks I will contact my hosting provider again.
    Will update this thread.

    chrisonline

    (@chrisonline)

    My hosting provider has wrote that no IP is blocked.
    All is working fine.

    As I wrote it is working with curl on my PC and Laptop.
    In my network and I have also tried it in the office.

    Both are working fine.

    The hosting provider does not block any IP’s.
    And the hosting proiver has added jetpack IP extra now in whitelist and it does also not work.

    AND my provider sayed the url http://www.colapps.net works and is same configured like the http://www.chrisonline.at!

    • This reply was modified 10 months ago by  chrisonline.
    Plugin Support Dat Hoang

    (@htdat)

    Hi,

    I’ve run this command across servers and the results are different.

    curl -A "Jetpack by WordPress.com" -d "<methodCall><methodName>demo.sayHello</methodName></methodCall>" http://www.chrisonline.at/xmlrpc.php

    1. From my personal VPS in Singapore: the result is good.
    2. From a VPN with the IP address in Austria (the same country with your hosting): the result is good.
    3. From our WordPress.com servers in US: the result is 404.
    4. From my personal IP address in Asia: the result is 404.

    Based on these results, I guess that your hosting provider is blocking IPs for some specific countries.

    Can you please reach them again regarding this issue?

    If they still say everything is fine, please let us know how we can contact them.

    Cheers,

    chrisonline

    (@chrisonline)

    Thanks for the update.
    I have just now sent your results to my hosting provider.
    I will update this once I get feedback.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘This site cannot be accessed’ is closed to new replies.