• Resolved jonedwards80

    (@jonedwards80)


    Hello,

    I am currently getting a This report is unavailable (400) message on my dashboard for this plugin. Any suggestions?

    Thank you
    Jonathan

Viewing 13 replies - 1 through 13 (of 13 total)
  • Do you have any errors reported in Errors & Debug screen?

    BobFest

    (@bob33)

    Same thing in the last day or so on several sites (url & ga ids removed):

    Last Error detected

    Last Error: 2016-11-10 07:48:50: exception ‘Google_Auth_Exception’ with message ‘Error refreshing the OAuth2 token, message: ‘{
    “error” : “invalid_grant”
    }” in /var/www/vhosts/ … /httpdocs/wp-content/plugins/google-analytics-dashboard-for-wp/tools/src/Google/Auth/OAuth2.php:331
    Stack trace:
    #0 /var/www/vhosts/ … /httpdocs/wp-content/plugins/google-analytics-dashboard-for-wp/tools/src/Google/Auth/OAuth2.php(264): Google_Auth_OAuth2->refreshTokenRequest(Array)
    #1 /var/www/vhosts/ … /httpdocs/wp-content/plugins/google-analytics-dashboard-for-wp/tools/src/Google/Auth/OAuth2.php(240): Google_Auth_OAuth2->refreshToken(‘1/uxxxxxxxxxxM…’)
    #2 /var/www/vhosts/ … /httpdocs/wp-content/plugins/google-analytics-dashboard-for-wp/tools/src/Google/Service/Resource.php(215): Google_Auth_OAuth2->sign(Object(Google_Http_Request))
    #3 /var/www/vhosts/ … /httpdocs/wp-content/plugins/google-analytics-dashboard-for-wp/tools/src/Google/Service/Analytics.php(1909): Google_Service_Resource->call(‘get’, Array, ‘Google_Service_…’)
    #4 /var/www/vhosts/ … /httpdocs/wp-content/plugins/google-analytics-dashboard-for-wp/tools/gapi.php(277): Google_Service_Analytics_DataGa_Resource->get(‘ga:4xxxxxx4′, ’30daysAgo’, ‘yesterday’, ‘ga:sessions,ga:…’, Array)
    #5 /var/www/vhosts/ … /httpdocs/wp-content/plugins/google-analytics-dashboard-for-wp/tools/gapi.php(415): GADWP_GAPI_Controller->handle_corereports(‘4xxxxxx4′, ’30daysAgo’, ‘yesterday’, ‘ga:sessions,ga:…’, Array, ‘qr3_3xxxxxxxxxxx6’)
    #6 /var/www/vhosts/ … /httpdocs/wp-content/plugins/google-analytics-dashboard-for-wp/tools/gapi.php(805): GADWP_GAPI_Controller->get_bottomstats(‘4xxxxxx4′, ’30daysAgo’, ‘yesterday’, false)
    #7 /var/www/vhosts/ … /httpdocs/wp-content/plugins/google-analytics-dashboard-for-wp/admin/ajax-actions.php(108): GADWP_GAPI_Controller->get(‘4xxxxxx4’, ‘bottomstats’, ’30daysAgo’, ‘yesterday’, false)
    #8 [internal function]: GADWP_Backend_Ajax->ajax_item_reports(”)
    #9 /var/www/vhosts/ … /httpdocs/wp-includes/plugin.php(524): call_user_func_array(Array, Array)
    #10 /var/www/vhosts/ … /httpdocs/wp-admin/admin-ajax.php(91): do_action(‘wp_ajax_gadwp_b…’)
    #11 {main}

    sgetz1946

    (@sgetz1946)

    Also getting a very similar error to above.

    Clear the authorization and re-authorize.

    Thread Starter jonedwards80

    (@jonedwards80)

    hello,

    thank you, this has now worked.

    much appreciated for your responses.

    BobFest

    (@bob33)

    That fixed it. Thanks for your work on this great plugin Alin.

    Hi Alin,

    we encountered the same problem here on dozens of websites. We solved this be re-atuhorize each website… not very funny but it works. Could you tell us how to prevent this from happening again?

    Thanks for your work.

    bambino

    (@babybitch1976)

    I had this happen to a whole bunch of websites about a week ago. It was very time-consuming to go through every client website and reauthorize the plugin. Now it appears to have happened again. I have a business to run and don’t have time to do this forever! How do I prevent this from happening repeatedly?

    I LOVE THIS PLUGIN…

    But have to report new Errors >>>

    I am having the exact same problem. Clearing cache and re-authorizing the Plugin is only a temporary fix. When I check back days later the data is not being displayed on the dashboard.

    Last Error: 2017-01-31 15:50:43: exception ‘Google_Auth_Exception’ with message ‘Error refreshing the OAuth2 token, message: ‘{
    “error” : “invalid_grant” …….

    @imagemarket check out the FAQ page, you may have been exceeding the 25 tokens limit.

    • This reply was modified 5 years, 10 months ago by Alin Marcu.

    That worked. Thanks for the suggested fix, Alin!

    Hi,

    I also had this problem and cleared authorization and re-authorized. This fixed the problem however it has erased over a year of analytics data!!

    Is that supposed to happen? Is there a way to get it back?

    It is now only showing information from last week, when I used this fix.

    @marionnw, your data is stored in your Google Analytics account and the plugin has read-only access to it. For details see the FAQ Page.

    Do you have multiple Google accounts? What probably happened is that you have authorized the plugin using a different Google account (different from the one you initially used). Your data is still there, but probably in a different account.

    • This reply was modified 5 years, 7 months ago by Alin Marcu.
Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘This report is unavailable (400)’ is closed to new replies.