Support » How-To and Troubleshooting » This problem needs to be resolved.

This problem needs to be resolved.

Viewing 15 replies - 1 through 15 (of 36 total)
  • You have look what’s being spit out on line 1. <?xml… needs to be line #1. Not #2.

    could you rewrite that portion ..assuming you mean this part?
    <?php if (!isset($feed)) {
    $blog = 1;
    $doing_rss = 1;
    $more = 1;
    $charset = get_settings('blog_charset');
    if (!$charset) $charset = 'UTF-8';
    header('Content-type: text/xml', true);?><?php echo '<?xml version="1.0" encoding="' . $charset . '"?'.'>'; ?>

    part of my problem is i never have worked with php…
    thank ya kindly..

    Try downloading that file, and checking that there is not a blank line at the top of the file contents.

    What’s hard to understand about the advice Podz gave you above? Do you have a text or HTML editor or plain old Notepad where you can view the file in question to see if indeed there is a blank line there? I hardly consider his advice “ignoring you.”

    Do you have a blank line before that first <?php I’d be willing to bet that’s your problem. It’s either there or you’ve edited wp-blog-header.php somewhere.

    “podz started to help then just ignored me”
    My daughter, who is 10, asked if I would go out with her for a bike ride. Now, where exactly should my priorities lie ?

    well.. my apologies to podz and all concern ..frustration had set in ..which i think ya’ll can see and understand….
    how about we move forward and fix this problem ..white space has been checked and there is none ..i havent altered any files ..i have only done/do exactly as podz advises…
    how about someone paste their code for the rss file here and i will copy it to mine ..we can work forward from here… then, yes?
    thank you

    Alright, assuming you’ve calmed down a bit. I will throw in a link (but it come with my 2 cents). I am having beaucoups more problems than you and though your problem is not one of them, neither is a fault of the code.
    wp-rss2 has not changed significantly in the CVS so you can back up yours and download a copy from there:
    CVS wp-rss2.php
    A dime to a donut says we will have to track the problem down somewhere else, though.

    ’twas me above

    ok ..thx… getting the same error ..also get the error on commentsRSS…
    the error says ..external entity ..what external entity?
    maybe something to note both FeedBurner and FeedValidater say the same thing..
    one other note …it does work in IE ..but whats important is FireFox and places like FeedBurner..
    what do we try next..?

    caferg, every page on your new blog has a blank line as line 1, this will cause validation problems with all the feeds, rss, rss2 and atom. currently the index.php validates but I think that is a mistake as it claims to be xhtml and xhtml is suposed to be valid xml and having a blank line is not valid xml as you have already seen
    you have more problems than just a broken rss2 feed, time to start hunting it down.

    i been looking at other pages, though a programmer i am NOT… as with the RSS file there is now way, either through notpad or WP template CP, for me to move up a line ..there just isnt another line to move anything to..
    i did find this in the xmlrpc file ..indicating this is not an isolated problem ..and if someone was to ask the proper programmers ..there would be a fix..
    [strong]# fix for mozBlog and other cases where
    <?xml’ isn’t on the very first line
    $HTTP_RAW_POST_DATA = trim($HTTP_RAW_POST_DATA);[/strong]
    include_once (ABSPATH . WPINC . ‘/class-xmlrpc.php’);
    include_once (ABSPATH . WPINC . ‘/class-xmlrpcs.php’);
    // Turn off all warnings and errors.
    $post_default_title = “”; // posts submitted via the xmlrpc interface get that title
    $post_default_category = 1; // posts submitted via the xmlrpc interface go into that category

    though that says it is a fix, it isnt helping me?

    that is a fix specific to the xmlrpc file, you have a different problem that needs fixing.
    something about your server configuration is adding a blank line to the beginning of your pages.
    you do NOT have any blank lines in the scripts something else is adding them to the OUTPUT only.

    what file would be for the server config file you speak of? i’ll take a look at that…

    cafeRg, your wp-blog-header.php file appears to be returning a blank line if I request that page specifically. I can see this by communicating with the server using HTTP over a telnet session.
    If you haven’t tried replacing the wp-blog-header.php file that is on your server with the one from the download, you might want to.

Viewing 15 replies - 1 through 15 (of 36 total)
  • The topic ‘This problem needs to be resolved.’ is closed to new replies.