Support » Plugin: WooCommerce Multilingual - run WooCommerce with WPML » This plugins seems to be getting worse over the years

  • Apprique

    (@apprique)


    First of all, while this plugin is apparently in the WordPress plugin repository, it is impossible to update it without an active license, even on a test site. This is a security risk and therefore I wouldn’t be surprised if this is a violation of a WordPress policy.
    Second, and this is the worst about this plugin: prices are not synced across translations, so make sure to update prices for each language! We encounter a lot of inconsistencies happening when updating translations.
    Unfortunately we’re currently stuck with WPML in this project, but for a next project we will definitely try something else.

    • This topic was modified 1 month ago by Apprique. Reason: typo in title
Viewing 1 replies (of 1 total)
  • strategio

    (@strategio)

    Hi @apprique,

    We regret if you had troubles with WooCommerce Multilingual.

    When the site key is missing or the account is expired, WPML displays a message but it should not block the plugin. There’s a “dismiss” link if you are on a test site.

    Concerning the price synchronization, it’s hard to tell what’s the actual problem. Sometimes it could be an incompatibility with a 3rd party addon.

    Did you already shared this on our support forum? If not, I strongly advise you to do it so we can provide a dedicated support. Then, please paste the link here so I can follow up.

    Thank you!

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this review.