Support » Plugin: Advanced Custom Fields: Validated Field » This plugin don’t work with latest version of ACF

Viewing 5 replies - 1 through 5 (of 5 total)
  • Same problem… not recognizing my regular expressions

    It doesn’t work with “Advanced Custom Fields PRO” Version 5.5.7

    Strict Standards: Declaration of acf_field_validated_field::validate_field() should be compatible with acf_field::validate_field($field) in /{{PATH}}/wp-content/plugins/validated-field-for-acf/validated_field_v5.php on line 3

    If you can edit the plugin files, this will fix the error AT LEAST in my case it did and it still seems to work as it should.

    in plugin file validate_field_v5.php

    line 128
    add_filter( "acf/validate_value/type=validated_field", array( $this, 'validate_field' ), 10, 4 );
    –>
    add_filter( "acf/validate_value/type=validated_field", array( $this, 'custom_validate_field' ), 10, 4 );

    line 368
    function validate_field( $valid, $value, $field, $input ) {
    –>
    function custom_validate_field( $valid, $value, $field, $input ) {

    • This reply was modified 2 years, 8 months ago by  aatospaja.
    • This reply was modified 2 years, 8 months ago by  aatospaja.

    Thanks, currently I had to downgrade the ACF PRO plugin to v5.4.8. I’d like to wait for the official fix.

    This also did nothing to me! Any ideas?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘This plugin don’t work with latest version of ACF’ is closed to new replies.