Support » Plugin: WP Facebook Open Graph protocol » This Plugin does not work for me! No Content & Image

  • Resolved Umrah

    (@umrah)



    When I try to post on Facebook or try sharing from my website https://www.msgdigital.com using this plugin, the only thing I’m seeing is url. There’s no image and content. I tried another plugin but it doesn’t work for me either. When I used the Facebook Sharing Debugger with a specific post this is what I got:

    Object Missing a Required Value
    Object at URL ‘https://www.msgdigital.com/use-google-custom-search-engine-on-https-websites/’ of type ‘website’ is invalid because a required property ‘og:title’ of type ‘string’ was not provided.

    Inferred Property
    The ‘og:image’ property should be explicitly provided, even if a value can be inferred from other tags.

    When I checked my page source the og:title and the og:image are there. I am frustrated and don’t know what else to do. Please help!!!

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Chuck Reynolds

    (@ryno267)

    You posted this 10 min before I checked your site and can see you’re not even using my plugin.
    <!-- This site is optimized with the Yoast SEO plugin v4.0.2 - https://yoast.com/wordpress/plugins/seo/ -->

    You should ask them for support.

    I am indeed using your plugin. You need to check again. You probably checked it at the time when I deactivate it to try another plugin.

    • This reply was modified 1 year, 10 months ago by  Umrah.
    Plugin Author Chuck Reynolds

    (@ryno267)

    So your first problem is you have 2 plugins (I now see this one lower) doing OGP. You must only use one. They’re conflicting with each other when Facebook scans your site. Yoast has an option to disable that functionality or you can disable this one.

    Another issue is in my plugin you don’t have the ID of your personal profile in settings.. you added your profile URL. You can use findmyfbid.com to find your ID or look again at the plugin readme.

    Okay. Thanks for your quick response.

    I disable that feature in Yoast and I inserted the ID in the plugin but I still experience the same issue.

    Sigh. I don’t know what else to do. 🙁

    Plugin Author Chuck Reynolds

    (@ryno267)

    Now I see you only have Yoast active; which is fine.

    Using the Sharing debugger: https://developers.facebook.com/tools/debug/sharing/
    and
    Using the Object debugger: https://developers.facebook.com/tools/debug/og/object/

    So it seems FB can only scrape partial information from your site. I’d suggest at this point to flush any local cache you have on the site, or even temporarily disable any cache you may have.

    The issue at this point either lies in (1) facebook debugger being temporarily broken (it happens sometimes) or (2) something else on your site is blocking or not allowing the facebook scraper bot to do its job.

    The code from yoast’s plugin and mine are outputting properly to your site. There’s something beyond the plugins’ output causing problems that I can’t test or help you with other than what I’ve provided here.

    Cheers

    I was experimenting at the time to see if I could fix the problem. Your solution was indeed correct. BIG THANKS TO YOU MAN! The problem has been resolved. The issue was the plugin I installed name Autoptimize.

    Your plugin is great, so simple and get straight to the point.

    Thanks.

    Plugin Author Chuck Reynolds

    (@ryno267)

    Right on, glad you got that figured out 🙂
    That’s the point of the plugin… simple… does what it does. That’s it.
    Cheers man!

    hi guys;
    by default autoptimize outputs the CSS very early in the HTML, which in some cases (depends on exact AO configuration) can push the og-tags down to where Facebook is not looking anymore.

    To fix this (without ditching Autoptimize) you can either change settings (don’t inline or inline & defer CSS) or you can use the AO API to change the place where the CSS is injected (there’s example code in autoptimize_helper.php_example).

    hope this helps,
    frank

    Plugin Author Chuck Reynolds

    (@ryno267)

    Nice. Thanks for chiming in Frank. Cheers 🙂

    I reactivate Autoptimize and try your solution and it actually work. Thanks Frank 🙂

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘This Plugin does not work for me! No Content & Image’ is closed to new replies.