WordPress HTTPS (SSL)
[resolved] This plugin BREAKS the site RSS FEED (11 posts)

  1. nicole2292
    Posted 3 years ago #

    When this plugin is activated my site RSS feed is broken and shows the common error:

    XML Parsing Error: XML or text declaration not at start of entity

    Line Number 3, Column 1:<?xml version="1.0" encoding="UTF-8"?>

    I know it is definitely this plugin as I have systematically activated and de-activated all plugins and the site theme and found that this is only the culprit which is breaking the feed.

    This error is usually to do with whitespace in the php (which there was in the file wordpress-https.php) However even after I have gone through and removed all line breaks outside of the php tags it still breaks the feed.

    PLEASE HELP - the plugin doesn't work with worpress as it should.

    I am using WordPress 3.1.3


  2. nicole2292
    Posted 3 years ago #

    Sorry thought I was posting in the forum for the Pluging WordPress HTTPS Version 1.8.5.

    Since it seems that it has not shown up in the topic title as [Plugin: WordPress HTTPS]

    I would just like to clarify that this is the plugin I am talking about.

  3. nicole2292
    Posted 3 years ago #

    I have done some further investigation on the wordpress-https.php file and the problem does not seem to be related to the whitespace at all.

    I have found that if I comment out line 448 ob_start(array(&$this, 'process')); the problem goes away.

    I hope this info is helpful to the plugin owners to drill down further and identify the actual problem.

    Help with this matter is URGENTLY REQUIRED. A plugin is no good if it breaks core site functionality like feeds.

  4. nicole2292
    Posted 3 years ago #

    Does no one else care about this issue? Surely there are other wordpress users out there who require both feeds and secure pages on their website. It's not a strange request...

    Please help???

  5. kansascoder
    Posted 3 years ago #

    We are getting ready to install this plugin on our blog (a network of 30 blogs) and will require RSS to work. Thanks for posting the fix, errr..workaround... Nicole2292. Any idea what the implications of that are? Do you now get the RSS feeds on your https pages?

  6. nicole2292
    Posted 3 years ago #

    Hi Kansascoder,

    I didn't actually find a fix for this issue so we cannot have wordpress https activated on our site. I was hopeing the developers could shed some light on the problem but I have had no response.

    Instead we are using the Force SSL plugin on our site and it seems to be working. However we have had to modify that plugin to suit out needs and it did not truly "force SSL" for everything so instead I have had to make quite a few changes to some of the plugins and the template of our site to ensure everything is coming over SSL with no issues.

    All this work leaves me wondering why isn't SSL a standard feature of WordPress?

    Let me know if you have any more questions.



  7. kansascoder
    Posted 3 years ago #

    Bummer about that support. We are just using the 2 fields in the wp-config to force ask on the login and trout the admin pages and it is working great even with network on iis7. Go figger!

  8. function5
    Posted 3 years ago #

    The plugin breaks my feed as well - same error. I've tried to use other plugins but they don't work the way I want them to whereas this one does albeit the feed issue.

    If someone could post a workaround or fix the bug in this, that would be great.

  9. Mvied
    Plugin Author

    Posted 3 years ago #

    Hey all,

    Apologies for the lack of updates and support. Sometimes life throws us curveballs. :)

    I'm about ready to push out version 1.9, but I wanted to make sure this issue is fixed before I do. Are you accessing your feed over HTTPS? Also, is there any way you could send me a link to the broken feed?


  10. nicole2292
    Posted 3 years ago #

    Hi there Mvied,

    Great that you are updating the plugin as it is a really good plugin and such a shame this problem existed.

    Sorry I cannot send you a link to the non-working feeds as the site I was having the problem with is now live and the feeds are in use with a different https plugin.

    No we are not accessing the feeds over https.
    The feeds are simply at http://www.domainname.com/feed

    It just seemed that whenever the wordpress https plugin was activated the feeds at http://www.domainname.com/feed broke. So should be quite easy for you to replicate.

    I think that maybe this problem has gone away with 3.2.1 as I have a new site I'm working on now and just to test I installed the wordpress https plugin on this site and the feed did not break.

    If that is the case your job is easy :)



  11. Mvied
    Plugin Author

    Posted 3 years ago #

    Hi Nicole,

    Thanks for the reply. Actually, I've tried this on every WP version since 2.7 and can't replicate the problem. The only thing I can think of is that the output buffering (ob_start(array(&$this, 'process'))) was bugging out on the feeds for a particular server configuration.

    If anyone has this issue or can replicate it, let me know and I'll look into a fix.


Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress HTTPS (SSL)
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic