Support » Fixing WordPress » This page isn’t working

  • Resolved Dav-Press

    (@dav-press)


    Hi Everyone,

    Please I need permanent solution to this problem. It is now very disturbing.

    For about four weeks now, I haven’t been able to access my login page. Each time I try, I get the below error message:

    This page isn’t working
    library.uniben.edu redirected you too many times.
    Try clearing your cookies.
    ERR_TOO_MANY_REDIRECTS

    I have cleared cookies, but that didn’t solve the problem.

    I need your help please.

    Thank you in anticipation of your help

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Moderator t-p

    (@t-p)

    Try manually resetting your plugins (no Dashboard access required). If that resolves the issue, reactivate each one individually until you find the cause.

    If that does not resolve the issue, access your server via SFTP or FTP, or a file manager in your hosting account’s control panel, navigate to /wp-content/themes/ and rename the directory of your currently active theme. This will force the default theme to activate and hopefully rule-out a theme-specific issue (theme functions can interfere like plugins).

    First, try to contact your web host to see if they can help.

    Second, if your host can’t, most probably it is due to the plugins that has issues with the redirect. Try to rename your plugins folder to something else like plugins-old and see if this issue persists, if this solves the issue, then one of your plugins is causing this error.

    Hope you are able to resolve this issue soon!

    I have had the same problem for a year ago, and as websprout writes.
    The easy and probably the best way is to rename det plugin directory.

    And one after another make a plugin folder and copy them over and activate them. to find the guilty plugin.

    it’s time consuming, but that was what i did. and found out that i had a malfunction in on of the plugin. that was to old. it happened after i had updated the website.

    I hope you succeed. quick so you can move on 🙂

    Thanks everyone for your help. I really appreciate your sincerity. However, the problem still persists.

    I deactivated all my plugins, but that didn’t set it right. I renamed the plugins folder, to no avail. I renamed the themes directory, same error. Now, while deactivated, I deleted all my plugins, and the problem is still there.

    For the host, I don’t have access to the host. I only manage the library side of a university website, but I have access to my files via FTP. I have contacted the university’s webmaster, and he thinks the problem is with the theme, and he recommends dropping the site completely, and installing afresh. For me, that sounds like the very last option, because I have made a lot of changes to the CSS and PHP files, and I’m not willing to start any fresh installation and backing up and uploading and replacing process, at least, not at this time. If the actual problem can be figured out and resolved, that will be relieving, in case it happens to me or someone else in the future.

    Looking forward to your help.

    Thank you people

    University webmaster is right, a fresh install would be great.
    Make sure backup all of the content files and database. Better install a fresh WordPress site on the subdomain or another place and after finishing the site move to the main domain.

    There are still two ways you can try before you do a new install:

    First is to enter the following two lines into your config.php (at the bottom):

    define(‘WP_HOME’,’https://library.uniben.edu’);
    define(‘WP_SITEURL’,’https://library.uniben.edu’);

    If it still doesn’t help, then rename your .htaccess file (backup first) so that the server will create a new .htaccess file, this new .htaccess file may solve this issue.

    Hope this helps.

    Oops! I didn’t see the last suggestion from @websprout before I started a new install. I tried replacing several files yesterday with new ones, and none of those fixed the problem. It was frustrating, so I had to go with a fresh install. But somehow, I feel the .htaccess suggestion would resolve the problem, however, I have started afresh.

    Thank you good people for all the suggestions. At least, I have learned things I didn’t know before now from you all.

    Gracias!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘This page isn’t working’ is closed to new replies.