Support » Fixing WordPress » This page isn’t loading JavaScript properly

  • I have my own made template and in every plugin who I used to make form this problem is still appearing.

    This page isn’t loading JavaScript properly, and the form will not be able to submit. Please check out our troubleshooting guide for details on resolving this issue.

    Can you give me some help with this ? Pls
    I deactivated all other plugins than wpforms and issue is still occurs .

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Hey there.

    It looks like you’ve got a JS function called animateValue which is being called 5 times in the footer of the linked page. It’s throwing the following error:

    TypeError: Cannot set property 'innerHTML' of null

    This is because the first argument that’s passed in, obj, is trying to find an element with an ID that doesn’t exist. These are the lines I’m referring to:

    const obj = document.getElementById("value");
    const obj1 = document.getElementById("value1");
    const obj2 = document.getElementById("value2"); ...

    If you comment this entire block of JS out in the footer, the contact form submits successfully.

    Let me know if you have any more questions about either fixing the above JS or where it may be coming from. Hope this helps!

    Thread Starter myszwa

    (@myszwa)

    Thanks very much for your help @mikachan !
    Unfurtunelly the problem still occurs . My site doesn’t throw any errors in console . What is happening 🙁 I spend to much time to fix it and i don’t have an solution . That is sick !

    You’re welcome. Hmm, that’s strange. I can see you’ve fixed the console errors, and it looks like the Contact Form 7 form at the bottom of the page works. It’s just the WPForm contact form that isn’t sending. It looks like there have been similar issues in the past to this, and people have fixed it by changing their hosting.

    https://wordpress.org/support/topic/form-page-reloading-instead-redirecting-and-entry-not-saving/
    https://wordpress.org/support/topic/wpforms-stopped-working-reloading-instead-of-submitting-or-saving/

    This makes me think it’s possibly an SMTP mail problem. However, in general, I’d recommend only using one type of contact form plugin, especially on one page. They may be conflicting with each other.

    I’d also recommend trying in the WPForm support forums, as the plugin authors will have a better idea of what the problem might be: https://wordpress.org/support/plugin/wpforms-lite/

    Thread Starter myszwa

    (@myszwa)

    Thanks for your reply . Like you saw Contact 7 sends mails but on mobile I have problem https://www.youtube.com/watch?v=gtJA6Muxdr8 . This is still problematic , because in fact i don’t have any form who works properly on my sites .

    Your layout is breaking at mobile because this image: https://janik.noel-ns.pl/img/kontrola_jakości.png has a style of width: 1400%;, which forces the screen to be bigger than the mobile viewport. You can fix this by adding max-width: 100% to the image style, which I’d recommend adding to all images to prevent problems like this.

    From your video, it also looks like you’re seeing the zoom effect when you interact with any form elements. You should be able to fix this by setting the font-size of your form inputs to 16px, e.g.

    form.wpcf7-form * {
        font-size: 16px;
    }
    Thread Starter myszwa

    (@myszwa)

    @mikachan I was set the max width of images and form font . Problem still occurs . I have seen that styles are backing to usual (not media queries) when I am intearcting with form .

    Thread Starter myszwa

    (@myszwa)

    Is any function who disable zooming when i click on the input off form ?

    The images are now looking good, they seem to resize perfectly at a mobile resolution.

    It looks like the form font-size is now set to 8px. It needs to be at least 16px for it not to cause Safari to zoom in. (See this article for more information: https://uxcellence.com/2014/fix-ios-input-zoom)

    Thread Starter myszwa

    (@myszwa)

    I changed to 16px still nothing . I notice that I click on form displaing flex is changing direction from column to row .It’s weird! Safari don’t zoom . This thing is doing on mobile firefox/chrome/opera .

    Ah OK, I can see the form has shifted over to the left and now doesn’t fit on the screen.

    Try adding the following CSS:

    .wpcf7-form, .wpcf7-form input, .wpcf7-form textarea {
        width: 100%;
    }

    This should make your form elements line up and they shouldn’t disappear off the screen. You have a style that sets the textarea to 300px, which will be smaller than 100% at the smaller resolutions. If you want it to line up with the other inputs, just remove the 300px limit.

    I can’t see the flex changing direction, could you point out which element (e.g. class name) this is affecting?

    Whenever I try to optimize my website for core web vital my website JavaScript start doing issues. I tried all the important plugin but still my website is not optimizing and my speed is not improving. Can anyone give recommendation about how can i make my website fast. My website is
    https://naturalprocleaning.com/

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.