Support » Plugin: All in One SEO Pack » This page contains the following errors:

  • Resolved cdhodgdon

    (@cdhodgdon)


    My sitemap is not working, I get the following error on the xml page

    “This page contains the following errors:
    error on line 2 at column 6: XML declaration allowed only at the start of the document
    Below is a rendering of the page up to the first error.”

    I know this has to do with a blank or “white” line at the top of the page, so when I right click the xml page and view source I can see line 1 is blank. I have checked my functions.php and wp-config.php file to be sure they did not have any closing php brackets and no extra spots and they don’t. I have tested by turning off all the plugins and changing to the default template and its made no change.

    I have not uninstalled and reinstalled AINSEO, as I am not sure if it will remove all the custom SEO items I have put in for my pages and posts.

    I am currently downloading a copy of the site to place on a different server to see if I can replicate the issue. But the funny thing is that I migrated this site from another server (which still has the development site on it), and I added a fresh copy of AIOSEO to it, since I did not have it installed during development and it worked just fine even with having twice as many plugins in the wordpress installation and such.

    Would love any suggestions on this problem. Thanks

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support wpsmort

    (@wpsmort)

    @cdhodgdon The blank space or line can be in any file within your WordPress install which is what makes this difficult to troubleshoot. If you’ve eliminated all plugins and your theme then reinstall WordPress and see if that fixes it.

    All your settings and SEO data are stored in the WordPress database so you can safely deactivate and delete All in One SEO and you won’t loose your settings or SEO. Just make sure to take a backup of your database when doing anything on your site.

    @wpsmort

    Ok, I will remove the AINSEO then reinstall WordPress itself again (did it while I still have AINSEO on the site) and then reinstall it and see what happens. If there any way to search for an extra line or php ?> in a file. I am also getting ready to upload a copy of the entire site, using All-In-One Migrator to a different server and see what happens.

    I had the development site on a different serve, where it is still located, and I installed AINSEO on that copy of the site and it seemed to work correctly. So I am doing the same thing in reverse right now, taking it off the production server and cloning it back to my seperate development server and see if the new version has the problem over there. If it does work, then that would lead to a meaning that something on the production server is out of wack. If that is the case, what might be a cause from a server iteself?

    Plugin Support wpsmort

    (@wpsmort)

    Sadly I know of no way to search all PHP files to find a blank space or line. You just have to go through a methodical process of elimination.

    Plugin Support arnaudbroes

    (@arnaudbroes)

    We have a doc on this here – https://semperplugins.com/documentation/this-page-contains-the-following-errors/.

    If reinstalling WordPress doesn’t help, then I’d recommend disabling all other plugins, switching to the default theme and then reactivating them one by one to see if you can track down the culprit.

    Ok. Any idea on possible server issue, if pages are clean? I still FTP’ing the clone up, the bad part of living in a small rural town, so I have not been able to test the official site on the other server to see if it still happens.

    @wpsmort

    I uploaded to my developement server and everything worked as it should, so it has to be something in the server settings. Any idea?

    @arnaudbroes

    I have already done that, fresh WordPress Install, deactivation of plugins and even removed them, used default template, if with a brand new WP install and fresh AIOSEO install with nothing else, it still did the same thing.

    I have cloned the site to a different server at a different hosting location (different data center) and it worked correctly, so it seems to be something with a server configuration, any idea on what to look for?

    Plugin Support wpsmort

    (@wpsmort)

    @cdhodgdon No idea on what on your server would cause this. We’re only aware that this is caused by blank spaces in PHP files.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.