Support » Plugin: Pronamic Google Maps » This page can’t load Google Maps correctly.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Reüel van der Steege

    (@pronamic_reuel)

    Did you try setting the API key in the WordPress dashboard at the Google Maps > Settings page? Should work.

    Yes I have tried both ways I have tried adding API key via Google map plugin and via below code, and I have done all the settings

    <script async defer src=”https://maps.googleapis.com/maps/api/js?key=YOUR_API_KEY&callback=initMap”
    type=”text/javascript”></script>

    Please help me to solve this issue other wise I will have to remove your plugin and try any other?

    Plugin Author Reüel van der Steege

    (@pronamic_reuel)

    I had a look at the HTML source of your page and in the browser console and it seems you’re using the Google Script Loader on your site and have altered the script file /js/site.js in our plugin. The Google Maps scripts are now loaded twice and the first time without API key, which is why you’re seeing the “For development purposes only” background (the second load is apparently not being used).

    Original code near the bottom in /js/script.js

    
    	/**
    	 * Ready
    	 */
    	$( document ).ready( function() {
    		initialize();
    	} );
    

    Your altered code:

    
    	/**
    	 * Ready
    	 */
    	$( document ).ready( function() {
    		google.load( 'maps', '3',  {
    			callback: initialize, 
    			other_params: pronamic_google_maps_settings.other_params
    		} );
    	} );
    

    Please try adding key=API_KEY to the other_params parameter, as shown below (also see https://stackoverflow.com/a/14410783):

    
    		google.load( 'maps', '3',  {
    			callback: initialize, 
    			other_params: "key=API_KEY&" + pronamic_google_maps_settings.other_params
    		} );
    

    Thanks You so much for Quick help I confirm Issue have been resolved 🙂

    Hi I am using you plugin in one more website

    I am getting error “This page can’t load Google Maps correctly.”

    http://bygging-uddemann.co.kr/projects/

    While I have cheked on console I am getting bellow error:

    Google Maps JavaScript API error: ApiNotActivatedMapError

    I have made the same changes on http://bygging-uddemann.co.kr which you have suggested in above post for https://www.bygging-uddemann.se/projects/

    Please help me to solve this issue ASAP it’s urgent

    It seems the Javascript API is not activated on your API project. I suggest you to take a look at the Google Cloud Platform Console, to check if the Maps JavaScript API is enabled.

    Hi Thanks for reply now Maps JavaScript API is enabled. Still the same issue please check again Thanks

    Plugin Author Reüel van der Steege

    (@pronamic_reuel)

    Varsha, did you check the console?

    > You have exceeded your request quota for this API. See https://developers.google.com/maps/documentation/javascript/error-messages?utm_source=maps_js&utm_medium=degraded&utm_campaign=billing#api-key-and-billing-errors

    Are you sure that billing is enabled for this key also?

    Yes I have checked billing is enable even I have generated both the key from the same account but with project id and different key

    Plugin Author Reüel van der Steege

    (@pronamic_reuel)

    Were you able to resolve the request quota issue with your API key?

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘This page can’t load Google Maps correctly.’ is closed to new replies.