Support » Plugin: MapPress Maps for WordPress » This page can’t load Google Maps correctly

  • Resolved Greg Robertson

    (@517design)


    I’ve taken over a site by another developer. Site uses MapPress. I am getting this popup over the map “This page can’t load Google Maps correctly”. The map also repeats “For Development Purposes” across the back. I’ve created an API with google, added to the map settings, but still no change.

    Screenshot:
    https://snipboard.io/Ow78JU.jpg

    Thanks

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • 2cats

    (@2cats)

    Same problem — I just updated MapPress (free version) and I’m getting the same message. We have the API as well.

    Plugin Author chrisvrichardson

    (@chrisvrichardson)

    Hi,

    This may be caused by setting up the wrong libraries in the API key. You can try creating a new API key using the link in the FAQ:
    http://mappresspro.com/mappress-faq

    You can usually see more about the error by bringing up the JavaScript console (F12 in most browsers). If you provide a URL to your map, I’ll have a look for you.

    2cats

    (@2cats)

    Hi Chris, Thank you for the speedy answer! I used the error console in Firefox and discovered the client needs to update their billing account. Problem solved for us, thanks again!

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.