Support » Plugin: WP Featherlight - A Simple jQuery Lightbox » This is not compatible with woocomerce

  • Resolved dongsaigon

    (@dongsaigon)


    Hi author,
    Thanks for your plugin
    But can you make it compatible with woocommerce
    When i actived plugin Woocommerce, it can’t show popup
    When i deactived this plugin, it’s good again
    Thanks for your help

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Ozzy Rodriguez

    (@ozzyr)

    Hello @dongsaigon,

    Can you try adding the following to your theme (probably in your functions file):

    /**
     * Disable WooCommerce gallery zoom and lightbox
     */
    function themeprefix_disable_woocommerce_gallery() {
    	remove_theme_support( 'wc-product-gallery-zoom' );
    	remove_theme_support( 'wc-product-gallery-lightbox' );
    }
    add_action( 'after_theme_setup', 'themeprefix_disable_woocommerce_gallery' );

    Thank you
    I used this, but no magic thing happen, sir

    add_action( ‘wp’, ‘tu_disable_wc_lightbox’, 20 );
    function tu_disable_wc_lightbox() {
    remove_theme_support( ‘wc-product-gallery-zoom’ );
    remove_theme_support( ‘wc-product-gallery-lightbox’ );
    remove_theme_support( ‘wc-product-gallery-slider’ );
    }

    After updated lastest woocommerce today, it works. Thanks Sir
    Updated: Not woocommerce, it’s autoptimize plugin. i disable it and use normally

    • This reply was modified 9 months, 1 week ago by  dongsaigon.
    Plugin Author Ozzy Rodriguez

    (@ozzyr)

    Thank you and good luck, @dongsaigon!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘This is not compatible with woocomerce’ is closed to new replies.