Support » Plugin: Google Forms » "This is a required question" after every question

  • Resolved agalaski

    (@agalaski)


    Great plug-in! I’m totally excited about it. However, the form that I’m trying to add to my site has one major issue. There an image here (I can’t link directly to the form, because I haven’t made it live yet.) How do I get all of the fields to stop saying “this is a required question” underneath them? It’s not necessary even for the required fields, since they have an asterisk.

    Below is all of the custom CSS I’ve used (to remove the title, make missed required fields red, and attempting to get rid of the ‘never send passwords’ note, though that doesn’t seem to work). If you have any thoughts on how to remove that unwanted ‘required question’ text, I would definitely appreciate it.

    h1.ss-form-title { display: none; }

    div.errorbox-bad div.ss-item-required label {
    color: red;
    }

    div.ss-form-entry > div.ss-secondary-text {
    display: none;
    }

    div.password-warning {
    display: none;
    }

    div.ss-form-container li {
    list-style-type: none;
    }

    http://wordpress.org/plugins/wpgform/

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author Mike Walsh

    (@mpwalsh8)

    These sorts of questions are hard to answer without seeing the form but I’ll try. Even if you haven’t placed the form on a Post or Page and connected it to your site, as long as you’re using the Custom Post Type version of the form, you can use the resulting URL to share the form.

    Do you have validation enabled? If so, you’ll see those sorts of errors if the submit button has been pressed without answering the required questions.

    Other than that, if you can’t post a URL, can you post a screen shot?

    Thread Starter agalaski

    (@agalaski)

    Mike,

    Thanks for the quick response! I’m fairly new to WordPress and CSS (recently taken over editing for this website, and kind of learning on the fly) and this is the first plug-in I’m using from scratch, so I’m not sure if I’m entirely understanding your question about Custom Post Types and validation. (Sorry!)

    Here’s a link to the form as it looks as a live form from Google Drive: Google Drive Form

    Currently, I’m putting the form onto a page via the [gform form= <link to google drive URL for the form>’] that you discussed here: http://michaelwalsh.org/wordpress/wordpress-plugins/wpgform/sample-form/

    Here’s a partial screenshot of the page preview: Screen shot

    Is there some other way that I should be inserting the form into our site?

    Plugin Author Mike Walsh

    (@mpwalsh8)

    If you’re using the [gform ] shortcode, that is the old (and original) way to define forms. The new, and better way to do it is to use the Google Forms menu on the Dashboard to define the form using the UI. All of the shortcode attributes you may be using in the [gform] shortcode are on the UI for creating a form.

    Here is a post where I introduced the new method which has some screen shots. Once your post is defined you have more options including the ability to add it to a menu using the standard WordPress custom menu functionality. There are a number of new options which I only added in the Custom Post Type version of the WordPress Google Forms.

    As to your question – you may want to go back and look at your source Google Form as those “This is a required question” messages don’t come from the plugin.

    Thread Starter agalaski

    (@agalaski)

    Mike,

    Thanks for the heads up about the new way to do it. That’s very useful. However, I’m still getting the “This is a required question” message. I even tried recreating the form from scratch in Google Drive. The new form is here: Form on Google Drive

    If it helps, I did figure out where/when the text shows up in the Google form. If a question is required and you click in the textbox to answer it, but click out of the textbox without adding any text, that phrase appears below the box. But it shouldn’t be showing up when the form first loads. In this case the new form that is being linked has never had any of the fields marked as a required question, so it shouldn’t be showing up at all.

    Here’s a link to the form, which is published but not linked to anything else on our website right now: Form on WordPress via Google Forms plug-in

    Any thoughts?

    Plugin Author Mike Walsh

    (@mpwalsh8)

    Looks like new Google Forms have some new functionality. There is new Javascript code included with the form which does client side checking for required fields.

    If you add this to your Custom CSS those messages will go away.

    div.required-message {
        display: none;
    }
    Thread Starter agalaski

    (@agalaski)

    Perfect! Fixes the problem exactly. Thanks so much for you help!

    Plugin Author Mike Walsh

    (@mpwalsh8)

    I am glad this resolved it. I wrote up a post on my site about this issue. Google has definitely updated Forms again with new functionality.

    Hi there, I’ve tried the to enter the div.required-message {display: none;} into the form’s custom CSS using the new wordpress function for google forms but the “this is a required question” is still showing in my form. Can you help? Thanks

    Plugin Author Mike Walsh

    (@mpwalsh8)

    Do you have the Custom CSS checkbox enabled on the plugin settings page?

    I’m not sure. I went to the settings and it’s asking me to link our site to wordpress… sorry if that sounds dumb. I think we’re using ‘jetpack’? does that make a difference?

    It may be my permissions. I will check with our ultimate administrator and if they can’t do it, I’ll check back.

    Plugin Author Mike Walsh

    (@mpwalsh8)

    The JetPack plugin asks for a WordPress.com account to link your site to WordPress.com for statistics and a few other things. You should be able to ignore that warning as it will appear on every Dashboard page until you do it or disable JetPack. It has no bearing what so ever on WordPress Google Form.

    On the Dashboard->Settings->Google Forms page, look for Custom CSS and make sure the checkbox is checked to enable custom CSS. If it isn’t, the CSS you define for all forms (on the plugin settings page) nor the CSS which is form specific (on the Define Form page) will be output when the page is constructed.

    unfortunately, i don’t think my dashboard is set up that way. I have fields in which I can enter a CSS prefix, suffix, or form CSS… there is not a place specific to the path you mention. again, it may be a permissions issue for me? all i have is a navigation link to add google forms… i don’t see settings anywhere.

    Plugin Author Mike Walsh

    (@mpwalsh8)

    Yes, that sounds like a permissions issue if you cannot see the settings page. Settings should be one of the top level menus on the Dashboard on the left hand side.

    You can enter the CSS as part of the form but if the global setting to enable CSS, which you need to be an Admin to do, isn’t set, then your custom CSS will never be loaded. So check with your Admin and make sure it is enabled.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘"This is a required question" after every question’ is closed to new replies.