WordPress.org

Forums

[resolved] This is a really simple question (13 posts)

  1. juliatrops
    Member
    Posted 7 years ago #

    I set up my blog about a year and a half ago - and as my website has changed, so have the link addresses -

    problem is, I cant remember how to change the links at the top of the blog - I am using Connections reloaded, and while I could do it once, do you think I can do it again?

    Here is my blog -
    http://blog.juliatrops.com

    and the links at the top Home, Archive, Links, and About are all invalid and need to be changed. I've searched the forum, and I've also looked in my connections theme directory - do you think I can find anything? no.

    I have all my notes and will start looking through them too - I'm sure I should be able to find them at least, but something tells me it might be "that sort" of day....

    Can someone please spare me some pain, and tell me which file this info is kept in? pretty please? :)

  2. Joni
    Member
    Posted 7 years ago #

    Go under Presentations and choose the current theme, it should be in header.php.

    You may need to ensure that your theme's template files (files ending in *.css or *.php in the theme's folder) are CHMODed to 766 to allow editing through the WP Dashboard.

  3. juliatrops
    Member
    Posted 7 years ago #

    Hi thank you! yes, I was there (theme editor), and have gone through all the files, but either my eyes are blind or I just cant read or maybe even both. It is not in my header.php. Yes, all the files are editable by me. Thank you for your very quick response!

  4. juliatrops
    Member
    Posted 7 years ago #

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head profile="http://gmpg.org/xfn/1">
    	<title>
    		<?php if (is_404())
    			_e('Error 404 - Not Found &raquo; ');
    		elseif (is_search())
    		{
    			_e('Search Results for ');
    			echo '“'.$s.'” &raquo; ';
    		}
    		else
    			wp_title(' ');
    
    		if(wp_title(' ', false)) echo ' &raquo; ';
    		bloginfo('name'); ?>
    	</title>
    
    	<meta http-equiv="Content-Type" content="<?php bloginfo('html_type'); ?>; charset=<?php bloginfo('charset'); ?>" />
    	<meta name="generator" content="WordPress <?php bloginfo('version'); ?>" /> <!-- leave this for stats please -->
    	<meta name="author" content="Ajay D'Souza" />
    	<style type="text/css" media="screen">
    		@import url( <?php bloginfo('stylesheet_url'); ?> );
    	</style>
    	<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="<?php bloginfo('rss2_url'); ?>" />
    	<link rel="alternate" type="text/xml" title="RSS .92" href="<?php bloginfo('rss_url'); ?>" />
    	<link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="<?php bloginfo('atom_url'); ?>" />
    
    	<link rel="pingback" href="<?php bloginfo('pingback_url'); ?>" />
    	<?php wp_get_archives('type=monthly&format=link'); ?>
    	<link rel="shortcut icon" href="<?php bloginfo('url'); ?>/favicon.ico" />
    	<?php wp_head(); ?>
    </head>
    
    <body>
    <div id="rap">
    <div id="header">
    	<ul id="topnav">
    		<li><a href="<?php bloginfo('url'); ?>" id="navHome" title="Posted Recently" accesskey="h">Home</a> | </li>
    		<li><a href="/about/" id="navAbout" title="About the Author" accesskey="a">About</a> | </li>
    		<li><a href="/archives/" id="navArchives" title="Posted Previously" accesskey="r">Archives</a> | </li>
    		<li><a href="/links/" id="navLinks" title="Recommended Links" accesskey="l">Links</a> | </li>
    		<li><a href="/contact/" id="navContact" title="Contact the Author"
  5. juliatrops
    Member
    Posted 7 years ago #

    <ul id="topnav">
    		<li><a href="<?php bloginfo('url'); ?>" id="navHome" title="Posted Recently" accesskey="h">Home</a> | </li>
    		<li><a href="/about/" id="navAbout" title="About the Author" accesskey="a">About</a> | </li>
    		<li><a href="/archives/" id="navArchives" title="Posted Previously" accesskey="r">Archives</a> | </li>
    		<li><a href="/links/" id="navLinks" title="Recommended Links" accesskey="l">Links</a> | </li>
    		<li><a href="/contact/" id="navContact" title="Contact the Author"

    The info in this, which I edited about a year and some ago, I can not find. This is what I am looking for... where oh where can it be?

  6. ClaytonJames
    Member
    Posted 7 years ago #

    This is what I am looking for... where oh where can it be?

    <div id="header">

    I believe everything in your last post will be located in "header.php" of the theme file as suggested by jonimueller.

    Edit: lines 39 to 43 to be exact, unless you have made a lot of modifications.

  7. juliatrops
    Member
    Posted 7 years ago #

    Hi Clayton, thank you yes, you are correct.

    I am looking for the specific naming of /about/ /links/ /contact/ - currently these links are set to http://www.juliatrops.com/about.html, http://www.juliatrops.com/links.html and http://www.juliatrops.com/contact.html -

    this is the information I need to change. Thank you for trying to help! :)

  8. juliatrops
    Member
    Posted 7 years ago #

    Hi Clayton, thank you for editing your post to suggest specific lines. I have posted my exact header.php in post 4 - I dont have the links to my website juliatrops.com/etc in the header.php. I dont remember doing much modifications to the theme other than the top image and the top nav - everything else is pretty much the same (from what I can remember, anyway.)

    I cant tell you how many times I have gone through each of the .php files, looking for these specific links. They must exist because they are there and clickable.

    And wouldnt you know it, I cant find all my notes. (sigh)

    edit to add:

    where are these definitions?

    navAbout
    navLinks
    navContacts

    ?

  9. juliatrops
    Member
    Posted 7 years ago #

    As there are three other topics,
    http://wordpress.org/search/navAbout?forums=1

    one of which did not receive any answer for solution, I have to conclude that this is not a simple question afterall.

    I guess I will keep looking. I did it once, I am sure I can do it again. Thank you all for trying to help anyway.

  10. Joni
    Member
    Posted 7 years ago #

    The links to the pages currently point to WP Pages using a permalink structure. Your actual pages are HTML pages. Why were they taken out of the WP Page structure?

    You can just go ahead and create hard coded links to them I suppose. With the *.html extension.

  11. Joni
    Member
    Posted 7 years ago #

    It's no guarantee that every question will get answered. And it would be nice if the folks who did have their problem solved would change the thread to [RESOLVED] so that folks like yourself who are searching for answers to their questions can zone in on a solution!

    :-)

  12. juliatrops
    Member
    Posted 7 years ago #

    LOL! Hi Joni! yes, the "Resolved" definitely helps things!

    The html pages are on my website http://www.juliatrops.com - which is separate from the blog - blog.juliatrops.com.

    re: permalinks - I found a reference to the permalink in one of the other questions - so checked mine, and they are all default already, so no changes needed to be made.

    And yes, those top links are hard coded -

    But where did I hardcode those .html pages???? arggggh!!!

    LOL!

    edited to add, not to where I hardcoded them, but where is the hard code WRITTEN to reference those hardcoded pages!! :)

  13. juliatrops
    Member
    Posted 7 years ago #

    oh, you know what... I am remembering that i tried to make my blog my main website. maybe I had those as page names??? and then when I decided to continue with a main webpage and ta blog on the side (that sounds so decadent lol!) and I deleted those pages... therefore they dont work??? shoot. I cant remember.

    okay, lets try this... am going to hardcode where I think it should go...

    <div id="header">
    	<ul id="topnav">
    		<li><a href="<?php bloginfo('url'); ?>" id="navHome" title="Posted Recently" accesskey="h">Home</a> | </li>
    		<li><a href="http://www.juliatrops.com/about/about.html" id="navAbout" title="About the Author" accesskey="a">About</a> | </li>
    		<li><a href="http://www.juliatrops.com/art_links/art_links.html" id="navLinks" title="Recommended Links" accesskey="l">Links</a> | </li>
    		<li><a href="http://www.juliatrops.com/contact/contact.html" id="navContact" title="Contact the Author" accesskey="c">Contact</a></li>

    .... and yes! it works!!!!

    Resolved!!
    Thank you so much!

    `

Topic Closed

This topic has been closed to new replies.

About this Topic