WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] "This is a page." I create and save but no content shows (8 posts)

  1. mmoconnor
    Member
    Posted 7 years ago #

    My posts work fine but no matter how many pages I create, how much content I put in them and how many times I save them, the page's content is: This is a page.

    I can see the content and the html in the edit box before and after I save it. I can go back and edit it again and again. But I cannot get it to appear on the page!

    The post preview always shows: This is a page.
    The blog page itself always shows: This is a page.
    But I can see my content in the edit box.

    I must be missing something really obvious here! I think I am saving but not publishing but I don't see a button anywhere that says "Publish."

    Please please please tell me what I am doing wrong!

    Thank you!

  2. moshu
    Member
    Posted 7 years ago #

    Paste your page.php file to http://wordpress.pastebin.ca and post back with the URI.

  3. mmoconnor
    Member
    Posted 7 years ago #

  4. moshu
    Member
    Posted 7 years ago #

    I meant the page.php template file of your theme.

  5. mmoconnor
    Member
    Posted 7 years ago #

    wp-content/themes/1105/page.php

    http://wordpress.pastebin.ca/526399

    Sorry about that!

    Thanks again.

  6. moshu
    Member
    Posted 7 years ago #

    If the theme came with that template file and you didn't edit it... then the designer of that theme has a lot to learn about WP.

    Try to replace the file with this:
    http://wordpress.pastebin.ca/526443

  7. mmoconnor
    Member
    Posted 7 years ago #

    Thank you! It works now! The page looks kind of funny but everything is there!

    http://www.aliveworldwideriches.com/aliveworldwide/about/

    I did not edit the template. I am a WP newbie.

    Thank you again!

  8. amadeus39
    Member
    Posted 7 years ago #

    I'm having the same problem as mmoconnor :

    I can see the content and the html in the edit box before and after I save it. I can go back and edit it again and again. But I cannot get it to appear on the page!

    The post preview always shows: This is a page.
    The blog page itself always shows: This is a page.
    But I can see my content in the edit box.

    I am using the default WP 2.3 theme, but did momentarily switch to another theme to take a look at it, then went back to the default theme.

Topic Closed

This topic has been closed to new replies.

About this Topic