Support » Plugins and Hacks » "This Event Has Passed" (No it hasn't)

"This Event Has Passed" (No it hasn't)

  • I’m not sure what I’m doing wrong. Does anyone else have this issue
    Is it one of the settings?

    I see the event on the calender but when I click on it, it redirects to a page where it says “This Event Has Passed”

    I searched for the answer, but it says this issue should be resolved on 2.0.5, I’m on the latest version 2.0.11

    Please Advise
    Your Help is greatly appreciated


Viewing 8 replies - 1 through 8 (of 8 total)
  • Hi holanz,

    Try deactivating all other plugins to see if there’s maybe a conflict there. If that doesn’t work, try reverting to the default WordPress theme to see if it’s a conflict with your theme. Let me know if that works.

    I’m also using 2.0.11 (just installed it this week) and set up a test event. I’m getting the same “event has passed” message.

    I deactivated all the plugins (Akismet, Contact Form Plugin, Google Analytics for WordPress, No Page Comment, and The Events Calendar) one by one and then all at once (except the Event Calendar, obviously) and still got the message.

    I also reverted through a couple of themes, same result. I was looking at the Pro-level because I have a recurring event I am hosting, but I’d like to get this issue resolved first.



    More info: In the Single page, it’s posting the timestamp of the current system time, and not the event date that I set.

    Hi fajalar,

    Can you please provide some specific examples and then provide me wp-admin access so I can take a look. Please to email pro [at] tri [dot] be and reference this thread. Do I have permission to deactivate all other plugins and switch the theme myself?


    Email sent. Thanks!

    I am having the same issue.

    I can create an event fine, and everything works great. However, if I edit the event after creation, something changes and instead of going to the /event/XXX page, I am redirected to /venue/XXXX.

    The link on the calendar displays correctly, as “/event/XXX”, and the pop-up has the correct information/date/etc. But as soon as I click on the link, I am redirected to /venue/XXX (the venue is whatever venue I happened to enter for that particular event).

    It displays a message of “this event has passed”, and the ‘date’ of the event becomes the date of my most recent edit, and not the actual date of the event.

    In the admin, however, the date still appears to be correct.

    As a work-around, I’ve currently been deleting and re-creating events to get it to work, but it’s becoming a hassle.

    This is for a corporate client, and I was looking into the “Pro” version for them, but I really do need it to be working before I can approach them about that.

    Thank you in advance for any help you can provide.

    Any update on this? I found a copy of 2.0.5, pulled the single.php up, and did a scan of the code. Didn’t see anything different between 2.0.5 and 2.0.11 but I may have missed something.

    I can pull the plugin and run the first event manually for now.

    Hi fajalar,

    Thanks for sending admin credentials. I logged in, installed the Twenty Eleven theme, activated it and poof, it worked fine. Unfortunately as mentioned in our sticky thread (http://wordpress.org/support/topic/welcome-the-events-calendar-users-read-this-first), we are unable to help with with customization, styling or integration issues not caused by bugs with The Events Calendar.

    I would suggest trying to contact the theme author to describe the issue and see if they can help you. Other than that you could also try the 3.0 beta to see if that fixes things for you. If you’re interested, please send an email to pro [at] tri [dot] be with a request to try the 3.0 beta.

    @brainstormjoe – sorry to hear you’re having a similar issue. I wonder if this is a similar theme conflict. Have you tried switching to the Twenty Eleven theme? If so, and the issue is still there you might also want to try the 3.0 beta. If so, please follow the same instructions I gave above.

    I hope that helps guys!


Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘"This Event Has Passed" (No it hasn't)’ is closed to new replies.