Support » Plugin: Contact Form 7 » This email address does not belong to the same domain as the site.

  • Mitch


    Just upgraded and got a config error
    This email address does not belong to the same domain as the site.
    Our site needs the different domain as we are being redirected from another site using their domain
    so each site on the network has to use their personal email account How do I fix it and if there is no way please ad a switch to turn that one feature off.

Viewing 15 replies - 1 through 15 (of 74 total)
  • camscorner


    I have the same error. This doesn’t make sense to me but then I am no techie. The From field is for the person completing the form. They may not even have a domain. What am I missing here?



    In my WP installation, with Contact Form 7, under the “Mail” tab, I have the “To” field set up with an email that belongs to the same domain as the site.

    In the “From” field, I have this:
    [your-name] <[your-email]>

    … but underneath, in red, there appears the message “This email address does not belong to the same domain as the site”

    But it does belong to the same domain as the site, since I am using the tag for the email address in the “To” field.

    Why is the logic flagging an error when there isn’t one?

    Thank you.



    What I found is you need to have an email address from your sites domain, meaning if your site is then your email has to be not or msn or hotmail, etc.

    It’s said that you ahem to create a email with your host, maybe something like

    Hope that helps,




    … but that’s the whole point: the email address I used with the [your-email] tag was using my site’s domain.



    Try this, because it worked for me:

    From: [first-name] [last-name] <>

    Of course is your domain and you might not have first and last names.




    Since the tag [your-email] refers to an email address that uses my site’s domain, then I guess you’re suggesting that there is some bug in the code logic which trips the error notice when that tag is used for the “From” field in the “Mail” settings tab.

    But, as camscorner suggested above, this doesn’t make sense anyway. If the [your-email] tag refers to the sender’s email address, then it will never match the domain name.

    We are talking about the settings: Contact > Contact form 1 (or whatever) > “Mail” tab ?



    I put the <[your-email]> in the message body. I believe the from is meaning from your site, not the person.



    I am talking about the “From” field under the “Mail” tab, which in my case has the [your-email] tag which refers to an email address which uses my site’s domain. Therefore something is wrong with the code, since the red error text is displayed below it.



    Lets clarify something As per the rules on this forum you need to start your own post.
    this post is going off the subject of my problem. Yours might be the same start your own threads if the author see a lot of threads on the same subject he might then do something about it.

    That being said I appreciate the replies But this message is a Message to the author since he will have to change the ruling on if its considered an error

    My problem is in the From field I have different email address there and would like the error not to show

    This email address does not belong to the same domain as the site

    since I want the different Email Address.



    In that case I’ll refrain from adding any more, except to say that the error therefore appears to have the capacity to rear its ugly head no matter what sort of email you put. ~~

    Neil Murray


    @mitch – so glad you have asked others to post their own thread.

    “Me too” & “Same Problem” comments are really unhelpful on a plugin with over 6 million installs.

    It makes it so much harder to answer the original posters question.

    Neil Murray


    @mitch – using an email address in the From: field that does not belong to the same domain as the site is becoming increasingly risky due to changes implemented by several prominent hosts to reduce email spam in the last couple of years.

    To minimize the risk of your form emails being considered as spam by other hosts the easiest way could be to setup an email address like to do all your form email sending.

    See Contact Form 7 Email Issues for an explanation of the issues involved.



    I got the message too. Turns out, it’s the distinction between the form and the mail routing.

    On the Form, [your-email] is the form fillers address.
    On the Mail tab, the settings are for Routing the mail. To is who you want the form data to go to and From is the address SENDing the form data. In this case, it’s not actually the person sending, it’s the web site. So From should match the server domain so it’s not seen by mail servers as spoofing or relaying.

    In many cases, To and From will be the SAME on the Mail tab. Just tested this and it worked fine and now passes the new configuration checker.

    Just be sure to put the From email address in brackets: <email>

    Sample images in the Help pages are now out of date. They do show using [your-email] in the From. This is now a mistake.

    More importantly, the change looses the From email address. So if you reply to the message, you end up replying to yourself. So now you ALSO need to add the following to Additional Headers:
    Reply-To: [your-email]

    It’s also a good idea to add a name to the From email address as that will carry forward in the correspondence and is better than “WordPress”.

    The format is: Name <email@domain.tld>

    This may seem a bunch of extra work but it does avoid your contact forms being seen as having spam-like qualities.



    I’ve known about this issue with CF7 for years which is why I always specified a replyto email address in the additional headers. The criteria have been fulfilled yet now it is harassing me to put my own top level domain replyto address in the From field.

    I don’t want to do that. I do not want to reply to myself. I do not want my clients to reply to themselves.

    People want to hit “reply” when a new email comes in, not copy the sender’s email address from the body of the email and compose a whole new message and reply!

    Can no one seriously understand this! jeez!

    I’ve also been using an SMTP plugin to validate all my emails and avoid PHP mail. The developers of CF7 have tried to fix something that wasn’t broken if you were using the SMTP plugin.

    Totally pointless update and just another hassle when working with WordPress.

    Osho Garg


    [your-name] <[your-email]>

    change <[your-email]> to email you’re using example: <>

Viewing 15 replies - 1 through 15 (of 74 total)
  • The topic ‘This email address does not belong to the same domain as the site.’ is closed to new replies.