• Resolved Bill White

    (@chipur)


    More of a heads up than anything. Suddenly started to receive this message when I started a new post and selected Classic Editor for block: This block has encountered an error and cannot be previewed.

    Did plugin troubleshooting and this plugin was the only one that triggered the message. I deactivated it and no error message, so I’ve left it deactivated.

    Embed Plus: 14.1.3
    WP: 6.0.1
    chipur.com

Viewing 15 replies - 1 through 15 (of 15 total)
  • I have the same problem. When this plugin is active, the classic block gives This block has encountered an error and cannot be previewed

    Thread Starter Bill White

    (@chipur)

    Go figure, right? And I still have it deactivated. Bummer is I wanted to do a post the other day with a YT vid and had to pass. Guess I could experiment with activating it and embedding after I write it. Wonder if they’re aware of the issue…

    I rolled it back to the previous version on one website and disabled it on another. Does the plugin author check their support questions?
    The Advanced Editor Tools (previously TinyMCE Advanced) plugin has not been updated forever and it looks like the author may never do it. I have built 3 websites using it and can’t find an supported alternative. If you find one please let us know.

    I added a support request to Advanced Editor Tools (previously TinyMCE Advanced) WP page at https://wordpress.org/support/topic/conflict-with-embed-plus-plugin-for-youtube/. The author responded to another request about a month ago saying he was working on an update. I hope he is monitoring it and gets it fixed.

    Thread Starter Bill White

    (@chipur)

    Good move. We’ll keep our fingers crossed. Thank you…

    I just sent a contact form to the plugin author at https://automattic.com/contact/.

    “I love Advanced Editor Tools (formerly TinyMCE Advanced) and can’t run my website without it. I understand that it takes resources to keep it up to date. I (and probably many of the 2000 daily downloaders) would be happy to pay a reasonable yearly fee to be able to continue to use it.”
    Please let me know how I can help to get the Advanced Editor Tools plugin updated!
    Maybe if other kindly contact them the plug will be regularly. 😉

    Plugin Author embedplus

    (@embedplus)

    We recommend reverting to the previous version of the plugin. We’ll explore the issue presented here in the meantime.

    Thread Starter Bill White

    (@chipur)

    Thank you

    Thread Starter Bill White

    (@chipur)

    To be sure, do you mean 14.1.2?

    Plugin Author embedplus

    (@embedplus)

    Yes, 14.1.2 would be the rollback version. Also, for anyone in this thread having issues with the editor: can you please paste here any browser console errors you see under the hood? It will help us pinpoint the real error behind “This block has encountered an error and cannot be previewed”

    Luisa Ravelli

    (@darkavenger)

    Hi,
    I didn’t see this topic before, so I wrote into another, sorry.
    Here’s the error that comes when I add the block (plugin 14.1.3, WP 6.0.2, PHP 7.4.29):

    react-dom.min.js?ver=17.0.1:9 ReferenceError: $media_buttons is not defined
        at HTMLDocument.<anonymous> (ytprefs-admin.min.js?ver=14.1.3:11:318)
        at HTMLDocument.dispatch (load-scripts.php?c=1&load%5Bchunk_0%5D=jquery-core,jquery-migrate,utils,regenerator-runtime,wp-polyfill,wp-hooks&ver=6.0.2:2:43064)
        at v.handle (load-scripts.php?c=1&load%5Bchunk_0%5D=jquery-core,jquery-migrate,utils,regenerator-runtime,wp-polyfill,wp-hooks&ver=6.0.2:2:41048)
        at Object.trigger (load-scripts.php?c=1&load%5Bchunk_0%5D=jquery-core,jquery-migrate,utils,regenerator-runtime,wp-polyfill,wp-hooks&ver=6.0.2:2:71515)
        at HTMLDocument.<anonymous> (load-scripts.php?c=1&load%5Bchunk_0%5D=jquery-core,jquery-migrate,utils,regenerator-runtime,wp-polyfill,wp-hooks&ver=6.0.2:2:72110)
        at Function.each (load-scripts.php?c=1&load%5Bchunk_0%5D=jquery-core,jquery-migrate,utils,regenerator-runtime,wp-polyfill,wp-hooks&ver=6.0.2:2:3003)
        at s.fn.init.each (load-scripts.php?c=1&load%5Bchunk_0%5D=jquery-core,jquery-migrate,utils,regenerator-runtime,wp-polyfill,wp-hooks&ver=6.0.2:2:1481)
        at s.fn.init.trigger (load-scripts.php?c=1&load%5Bchunk_0%5D=jquery-core,jquery-migrate,utils,regenerator-runtime,wp-polyfill,wp-hooks&ver=6.0.2:2:72086)
        at u.editor.initialize (editor.min.js?ver=6.0.2:2:12412)
        at c (block-library.min.js?ver=eaf9a7d8b936d26afead09af3f82b117:14:64287)
    rr @ react-dom.min.js?ver=17.0.1:9
    a.componentDidCatch.t.callback @ react-dom.min.js?ver=17.0.1:9
    An @ react-dom.min.js?ver=17.0.1:9
    ir @ react-dom.min.js?ver=17.0.1:9
    Br @ react-dom.min.js?ver=17.0.1:9
    unstable_runWithPriority @ react.min.js?ver=17.0.1:9
    xn @ react-dom.min.js?ver=17.0.1:9
    Ar @ react-dom.min.js?ver=17.0.1:9
    Pr @ react-dom.min.js?ver=17.0.1:9
    (anonymous) @ react-dom.min.js?ver=17.0.1:9
    unstable_runWithPriority @ react.min.js?ver=17.0.1:9
    xn @ react-dom.min.js?ver=17.0.1:9
    Nn @ react-dom.min.js?ver=17.0.1:9
    _n @ react-dom.min.js?ver=17.0.1:9
    ua @ react-dom.min.js?ver=17.0.1:9
    pe @ react-dom.min.js?ver=17.0.1:9
    Plugin Author embedplus

    (@embedplus)

    @darkavenger Thank you so much, that helps. A couple more questions:

    1. Does this issue break your whole admin page, or just specifically the Advanced Editor Tools block?

    2. Can you contact us using the email found in our plugin’s “Support” tab (look at the last bullet in there)? We may have a solution for the issue, and we can help you fix it with a patch before we are certain and release it to the wild for everyone.

    Anyone else in this thread that’s interested in an early fix is welcome to similarly contact us.

    Cheers,
    – EmbedPlus Team

    Plugin Author embedplus

    (@embedplus)

    We’ve pushed a new version (14.1.4) that may fix your issue. For now it can be directly downloaded here, please let us know if your issue is resolved: https://downloads.wordpress.org/plugin/youtube-embed-plus.14.1.4.zip

    Once we’ve confirmed things are good, we will release it as the new version for everyone (e.g. the WordPress autoupdater, etc.):

    Hi,
    in the previous error only the classic paragraph block was broken.
    This version (14.1.4) seems to work for me, no more errors.

    Thanks a lot!

    It is working now. Thanks for your help! Ann

Viewing 15 replies - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.