Support » Plugin: Testimonial Rotator » Third Star Missing in 5 Star Review

  • Hi,

    There seems to be a problem with 5 star reviews in the plug in. It will only show 4 stars for a 5 star review! If I press F12 to inspect the source code, I have noticed a possible problem. Correctly appearing stars have this code:

    <span class="testimonial_rotator_star testimonial_rotator_star_2"><i class="fa fa-star"></i></span>
    <i class="fa fa-star">
    ::before
    </i>
    </span>

    However, star 3 is missing the ::before. All other stars include the ::before.

    Is this a known issue and is a fix available?

    Many thanks!

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Hal Gatewood

    (@halgatewood)

    This is a new one for me. Can you try adding this CSS to your theme:

    .fa-star:before { content: "\f005" !important; }

    Maybe the !important will override whatever is causing that.

    Thanks,
    Hal

    Hi Hal,

    Sorry for such a late reply – been away.

    Your suggestion has not resolved the problem. I have recently installed the plugin on a different website and am getting the same issue.

    Having tried to find the problem, I have tested a bit further. Flagging a testimonial as either a 2 star or a 3 star rating outputs 2 stars in both cases on the frontend display. A 4 star review shows with 3 stars and a 5 star testimonial displays 4 stars.

    I think there is something in the “counting” code which is causing the issue.

    I hope this helps you work out the problem.

    Thanks,
    Chris

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Third Star Missing in 5 Star Review’ is closed to new replies.