• Resolved phelembae

    (@phelembae)


    all my recent posts display huge play and pause icons whenever the players it’s attached to my blog. I wish I could have the option to attach a picture so that you can see it clearly and maybe be able to advise me on what to do.

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Alec Rust

    (@alecrust)

    Hi @phelembae,

    Nothing has changed in the plugin, it still works as before.

    On the URL you provided, it looks like you have various errors that need to be resolved (see the browser console). Something is preventing the CSS from loading correctly.

    Try temporarily disabling all plugins except Protected Video to see if that fixes it, and enabling one-by-one to isolate which plugin is causing this.

    I wish I could have the option to attach a picture so that you can see it clearly and maybe be able to advise me on what to do.

    You can always provide a link to a screenshot, or upload a screenshot to Imgur or elsewhere, and embed it in a post in these forums with <img src=""> HTML.

    Thread Starter phelembae

    (@phelembae)

    Thank you for saying, “Something is preventing the CSS from loading correctly.”I quickly realize is the LiteSpeed catch plugin, therefore, after deactivating it, the error went out and when I activated the plugin it came back so definitely is the caching plugin, thanks for your assistance.

    Plugin Author Alec Rust

    (@alecrust)

    No problem, glad you got it sorted!

    Thread Starter phelembae

    (@phelembae)

    awesome thanks!!!

    Hi,

    I am facing the same issue, but also deactivating everything the problem is there.

    In particular, that is happening in a custom post type from MemberPress: the lessons.

    Plugin Author Alec Rust

    (@alecrust)

    @glanzi can you provide a link to a page with this issue?

    As mentioned above, the plugin itself is not causing this. Here’s a standalone version of the plugin: https://protected-video.alecrust.com/

    Thread Starter phelembae

    (@phelembae)

    1. Exclude The Page where you use protected video From Being Cache BY Any Caching Plugin Such as LiteSpeed /wp-rocket, etc.

    2. after this use incognito mode or simply clear browser cookies, visit the page, and the issue will be solved.

    I have faced this issue several times and the problem is always caching plugins on my side. since you deactivated every plugin the problem might be the cached version of the old website with the error. Therefore clear browser cookies/use different devices/ incognito mode.

    hope this helps

    • This reply was modified 1 year, 5 months ago by phelembae.

    Hi,

    You can check the issue here: https://planbproject.it/lessons/introduzione-al-corso. (If there is a message telling that the content is blocked, just click on ok. It’s not blocked but public.

    @phelembae I already did disable caching plugins and check it in incognito mode. The problem persist.

    I suppose there is something else that’s prevent CSS to be loaded, but I don’t know what could be.

    Another thing I tried was to disable everything but MemberPress and Protected Video Plugin. Issue wasn’t resolved.

    EDIT: I also sent an email to the support team at MemberPress to know if there actually is something that is preventing extra CSS to be loaded.

    • This reply was modified 1 year, 5 months ago by glanzi.
    Thread Starter phelembae

    (@phelembae)

    Would it be possible to try and disable member press also .the issue is exactly as what i have faced before but am not sure why is not resolved,check if maybe your hosting provider has some caching system by default on your cpanel/reach out to them.

    @phelembae

    Maybe I wasn’t completely clear (English is my second language, sorry): The plugin is working on posts and pages, but in a particular CPT (MemberPress lessons) it isn’t.

    Since my goal is to protect video in those pages (lessons), deactivating MemberPress isn’t an option.

    Thread Starter phelembae

    (@phelembae)

    ok, you can try MemberPress alternatives such as paid membership pro and Learndash [currently I am using protected video with LearnDash and I have no problem ]. Or simply use an alternative of protected video but I doubt you will find one that does the job perfectly for free.

    • This reply was modified 1 year, 5 months ago by phelembae.
    • This reply was modified 1 year, 5 months ago by phelembae.

    @phelembae Thank you for the suggestions, but I told that deactivating MemberPress isn’t an option.

    Anyway, for anyone who is facing the same issue, the solution is to add this snippet in functions.php:

    add_filter('mpcs_classroom_style_handles', function ($allowed_handles) {
    	$allowed_handles[] = 'protected-video';
    
    	return $allowed_handles;
    });

    MemberPress is preventing some CSS to be loaded in their lessons CPT, therefore you need to make it happen anyway with the script above.

    Cheers

    P.S. That should work for other plugins too (custom blocks or similar), just add the right handle to let the plugin’s CSS load in MemberPress classroom mode.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Theres an error with the plugin it displays large icons such as play and pause’ is closed to new replies.