Support » Plugin: Contact Form 7 » There was an error trying to send your message. Please try again later.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Takayuki Miyoshi

    (@takayukister)

    @digitalown I was having the same issues with many of our customer websites after updating the plugin to 5.1.1. The issue of failed sending appears to be created by the Google reCAPTCHA module, as once it is removed the sending starts working again. For almost all of these sites, I have found that rolling back the plugin to 5.0.5 using WP Rollback and either using reCAPTCHA v2 or no CAPTCHA at all solves the problem.

    @takayukister It would be mighty helpful if you could add a feature to select which reCAPTCHA version you want to use, as obviously many people aren’t having as much success with v3 as they were with v2.

    Hope this helps!

    Oh my god yes, please please let us choose which captcha version to use. V3 puts the captcha badge on every page of our site.

    @zenmagnets that is an easy fix to hide it though…

    Appearance > Editor > Stylesheet

    .grecaptcha-badge{
    	visibility: collapse !important;  
    }

    “There was an error trying to send your message. Please try again later.”

    Is the error border color orange or red?

    An orange error border indicates reCAPTCHA v3 is not working correctly on your site.

    You may see this error if you’ve:

    • previously used reCAPTCHA v2 with CF7
    • updated to CF7 5.1.1 or newer and
    • not changed your previous reCAPTCHA v2 keys to reCAPTCHA v3 keys at Contact > Integration.

    @s0ulfire, unfortunately when I use that code in my CSS, it seems to take out the captcha code entirely and the contact form no longer works. Example: https://zenmagnets.com/relations/#Contact

    Hi Takayuki Miyoshi

    It doesn’t work. The solution given above is not working.
    now, what I do?

    Regards

    lesero

    (@lesero)

    Hello,

    I also get the error message that this is about but I don’t have a colored frame. It is colorless. The strange thing is that other contact forms work on other subpages. I have ReCaptcha v3 and so it works on the other subpages as well. I have compared the settings and it should work in theory. I really don’t know what else it could be. I would be very grateful for help.

    I have WordPress 5.1.1

    Link to the subpage where the malfunction occurs:
    https://franz-automobile.com/autozentrum-elmshorn-2

    • This reply was modified 1 month ago by  lesero.
    • This reply was modified 1 month ago by  lesero.
Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.