Support » Plugin: Contact Form 7 » There was an error trying to send your message. Please try again later.

  • Resolved jazperson

    (@jazperson)


    Hi,

    We had development site for our website and when we made it live, our contact 7 forms doesn’t work and we have this error:

    There was an error trying to send your message. Please try again later.

    I already reset and removed recaptcha and we still get the error. Can you please help us?

    This is our live website – https://badgeraustralia.com.au/contact-us

Viewing 15 replies - 1 through 15 (of 46 total)
  • Plugin Author Takayuki Miyoshi

    (@takayukister)

    jazperson

    (@jazperson)

    Hi,

    Thank you for your response. It’s not a spam problem, the error is red border. So I guess that leaves us with the mail server problem. I will contact our hosting support if they can track the problem, but if not, I’ll reply here again and ask for help.

    The forms were working before on development site, but when the domain name was pointed to our new hosting, the forms stopped working.

    Robert

    christina88

    (@christina88)

    I have the same problem as jazperson. When I contacted my hosting support they said that all my settings look fine and that the problem must something else.

    I tried to reset my reCaptcha keys, same as jazperson and I also tried to configure WP Mail SMTP as shown in this hack I found in YouTube, still to no end.

    Any help would be greatly appreciated!

    Thank you!

    jazperson

    (@jazperson)

    I got this solved. It’s not the mail server. I changed the mail settings on the section of “to”, “from” and “subject”, but I only changed the “from” section.

    from “info@mydomai” to “wordpress@domain”. I don’t know why it only works with having this “wordpress@domain” to work instead of a real email address.

    Thanks.

    jazperson

    (@jazperson)

    Marking this as solved.

    christina88

    (@christina88)

    With me it still doesn’t work!

    I tried to replace my info@mydomain with wordpress@domain.

    Is it that I am not typing it right? I tried with:
    wordpress@domain
    wordpress@domain.com

    jazperson

    (@jazperson)

    Sorry, our website is badgeraustralia.com.au so ours is set to wordpress@badgeraustralia.com.au. Replace badgeraustralia.com.au with your domain name.

    I did everything that you did and the problem still persists D:

    • This reply was modified 1 year, 11 months ago by  zontir.

    I got the same error but with grey border. Any help?

    I am having the same issue :: Red Error – THERE WAS AN ERROR TRYING TO SEND YOUR MESSAGE. PLEASE TRY AGAIN LATER. The above fixes did not work. Any help would be greatly appreciated.

    I am having the same issue :: Red Error – THERE WAS AN ERROR TRYING TO SEND YOUR MESSAGE. PLEASE TRY AGAIN LATER. Can someone pls show us step by step so that we can really rectify this issue rightly.
    I appreciated that.Thanks.

    I’m having same problem as well. Error surrounded by red borders.

    I ran a test and subscribed a new user with new email address to see if the new user email arrived but it has not which leads me to believe wp_mail isn’t working.

    I tried creating a new form and kept all the default settings and it didn’t work either.

    Contact your hosting provider!. The problem is, they must have stopped all emails generated from Plugins/Scripts(because of spam). May be you can register your email(something like, info@domainname.com) at your control panel can solve your problem.

    I am getting the same error with no luck from my host… any help would be appreciated.

    dens1950: create a new user (use a different email address that you have access to), if the new user email doesn’t automatically come through then Wp_mail isn’t working. I solved this by installed WP Mail SMTP by WPForms plug-in and set up to use a proper SMTP mail account and it solved the problem.

Viewing 15 replies - 1 through 15 (of 46 total)
  • The topic ‘There was an error trying to send your message. Please try again later.’ is closed to new replies.